3

I have a problem with linking my Google Adwords to my Search Console and have tried to reverse engineer the issue to no avail.

  1. Go to Adwords > Tools and Settings > Linked Accounts > Search Console > Click Details
  2. The site URL that I am allowed to verify is http:// our account is a domain property on Search Console as well as having our https:// and http:// properties.
  3. I cannot verify the property in adwords

Recap

  • Domain property is verified
  • https:// url of the domain property is verified
  • https://subdomain on the domain property is verified
  • http:// verified
  • Google Adwords only gives me the option to connect to search console via the http:// url
  • I try to connect Adwords to search console and it cannot verify the property that is verified in search console!
2
  • When you say "as well as having our https:// property", does that mean that you have both the domain property and the prefix property for https verified in Google Search Console? Jan 22, 2021 at 20:16
  • Do you get an error message from Google Search Console when trying to verify the http prefix property? Jan 22, 2021 at 20:16

1 Answer 1

3

Google Adwords will not allow you to specify a protocol (http or https) when linking a "URL" to an Adwords account. (I quote "URL" because that is the terminology used by Google in the Linked Accounts section in Adwords, which suggests at the outset a mis-match between Adwords and Google Search Console's Domain Properties.)

enter image description here

I had assumed that because I had a Domain Property set up in Google Search Console that this would appear in the list of domains to link under Adwords... no such luck.

For whatever reason, Google does not display Domain Properties in the list of properties under your Google Search Console - it only lists URL Properties.

However, if you enter a URL manually (e.g. "www.mydomain.com") this will actually link to the Domain Property in Google Search Console, and you can see this under the Associations section in Google Search Console.

enter image description here

As you've established though, https is apparently not an option. Any URL entered defaults to http.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.