Windows Server 2012 R2 / IIS 8.5

I have a number of folders in C:\inetpub\wwwroot;

 - wwwroot
  - index.html
  - analytics (PHP app)
  - occupancy (PHP app)
  - rooms (ASP app)

In IIS my sites structure is;

 - Default Web Site (bindings config is http port 80 / https port 443)
  - analytics (application)
  - occupancy (application)
  - rooms (application)
 - Room Booking (bindings config is http port 8080)
  - files

In my Default Web Site I have created an application for each site. I am able to access localhost/analytics and localhost/occupancy without issue, but when I try to access localhost/rooms I get the following error;

HTTP Error 403.14 - Forbidden The Web server is configured to not list the contents of this directory. Most likely causes: A default document is not configured for the requested URL, and directory browsing is not enabled on the server.

However if I visit http://localhost:8080 I can see the application successfully.

So, how can I access the rooms application via localhost/rooms

I've made no other changes to system files. Little to no experience with IIS here.

  • Doesn't IIS require a default.aspx page even for applications? It's been several years since I worked with IIS, but as I recall, a default.aspx page called the actual application.
    – Trebor
    Commented Jan 5, 2021 at 17:35
  • Can you edit your question to include your configuration for the PHP applications and ASP application? A screenshot of the configuration would be enough for somebody to see what is going on and help you. Commented Jan 5, 2021 at 23:24
  • Just to clarify my comment above. IIS assumes that if you don't provide a default page, that you are attempting to browse the directory's contents-hence the error message. With a basic html site, you would have default.html, or index.html. With .NET, I always used a default.aspx page that loaded the code for the application.
    – Trebor
    Commented Jan 6, 2021 at 4:23

1 Answer 1


I managed to get this working by creating a new rooms application pool.

Then in default websites > rooms > basic settings I changed the application pool to the newly created rooms.

I still don't know why this worked but it has. Hope it helps someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.