0

I have a web app hosted on a server that was recently moved to a new location and has a new ip address associated with it. I am not well versed in networking or server administration so any help is appreciated.

My web apps cannot be accessed at all, I host them on IIS and have messed around with the ip addresses a little bit. I tried to point the domain to the new public ip address on godaddy. com. I tried changing the Forward Lookup Zones ip addresses on DNS Manager. But no luck.

The problem is, I ping the web app from my local machine ping mydomainname.com and get the new ip address of the server, when I ping the site from the SQL Server I get the old ip address.

I have looked at Windows Firewall Rules on the server and notice that there is a rule:

Forward 443 to Public

Forward 80 to Public

Also when I run:

nslookup
>set type=A
>mydomainname.com

I get two different ip addresses depending if I run it from the server or my local machine.

With all of this, I am able to access the websites from my server but from nowhere else.

Under DNS Manager in Forward Lookup Zones I have the websites added with the correct ip address too.

The sites are run on Port 443 and Port 80. I am wondering if I should remove that rule or not? Any help is appreciated.

Edit: On the server I run:

nslookup
>set type=soa
>mydomainname.com

It returns the correct 'primary server name` along with all of the TTL, retry, expire info, then 'internal address = my ip address'. But it is not the public IP Address. Also I will add that the Nameserver in the godaddy account is still the default, that has never been changed so I don't think that will be a problem because it worked on the old server.

4
  • 1
    Have you requested the authoritative DNS records? I.e., set querytype=soa – Trebor Oct 13 '20 at 2:38
  • As I'm not overly familiar with DNS, I will say that I think so. I went into the godaddy account that the domain name was purchased from and set the A record to point to the public Ip Address of the server. But I am unsure if the zone files are correct. And what exactly I am missing. – stupidQuestions Oct 13 '20 at 17:48
  • I will add that in DNS Manager I have the forward lookup zones set to the local Ip Address and not the public. Maybe this is wrong. – stupidQuestions Oct 13 '20 at 17:50
  • (I'm new, so not sure if policy is different here to on Superuser where I hang out a lot but if appropriate) what is the domain name and what IP are you supposed to be getting when you resolve it and what is the old IP? My guess is when you updated the domain name you did not increment the SOA record to reflect you had modified the zone. Its also conceivable there is an error in your zone – davidgo Oct 23 '20 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.