0

I installed the Wamp server stack on a loan machine (until new one arrives) to keep my site going. I configured the VirtualHost to point to port 7075. I included the directive to Allow All but it still coming up forbidden when trying to access from my laptop. I also have the domain pointed to it but again it is coming up with 403 Forbidden. What exactly is wrong with it?! I've gone over other questions similar and still no joy. Yes I do have it in the hosts file as well as I know some forget about that part but I ain't daft I do know what I'm doing.

Can someone please give me some guidance or advice on why it isn't allowing the site to be viewed on either local or the actual domain and the IP I'm using for the loan machine is 192.168.1.181 - also got this pointed to on internal port 7075 and external port 80 for the domain. I worked fine before when I was using Xampp but this time obviously decided to use Wamp but don't understand what exactly is the issue with it.

Oh I should point out I'm on Windows 10 not a Linux machine.

  • Why wouldn't you use port 80 for both internal and external connections? I use 80 all the time for my sites, even when accessed internally from over the LAN. – Stephen Ostermiller Sep 13 at 9:49
  • Tried that already and hadn't made any difference. The only difference was that it would of come up with the main front page of the Wamp server instead of a specific site I'd created. That still doesn't answer the question or help btw. I mean surely that is one of the first things I would of tried anyway you know. It is giving a 403 forbidden which should point out there is something not right somewhere but that is why I'm asking for advice on what I could try? Might I need a .htaccess file in place and if so what might I need put in there? – Dave Sep 14 at 15:30
  • If the main front page of the Wamp server is coming up, that indicates that the virtual host doesn't match. Did you configure internal DNS to be able to use the domain name of the site? If not, and you want to use an alternate name, did you add that name as a ServerAlias in your virtual host? – Stephen Ostermiller Sep 14 at 15:41
0

Give this solution a try and if it does not work please post your virtualhosts config file so we can see if there are any issues: https://stackoverflow.com/questions/26113258/wamp-virtual-host-not-working

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.