0

I have a problem when indexing in google search engine. There is a page https://frontext.ru/posts/2020-08-27-making-cross-browser-and-responsiveness-better, so a few days later I noticed that it was excluded from the search list. I began to understand and it turned out that Lighthouse for smartphones throws an accessibility error: enter image description here

Moreover, specific elements are not indicated. I checked the page and noticed nothing seriously wrong in contrast. I removed elements, replaced colors, nothing changed. Only code highlighting remains that looks like:

<pre class="hljs" style="display: block; overflow-x: auto; padding: 0.5em; color: rgb(51, 51, 51); background: rgb(248, 248, 248);"><span class="hljs-keyword" style="color: rgb(51, 51, 51); font-weight: 700;">if</span> (<span class="hljs-string" style="color: rgb(221, 17, 68);">"ontouchstart"</span> <span class="hljs-keyword" style="color: rgb(51, 51, 51); font-weight: 700;">in</span> <span class="hljs-built_in" style="color: rgb(0, 134, 179);">document</span>.documentElement) {
      <span class="hljs-comment" style="color: rgb(153, 153, 136); font-style: italic;">//if true</span>
    }</pre>

Tell me, what could be wrong, or is there another problem? Other pages with no highlighter are indexed without any problems. Nuxt.js site, if it matters.

3
  • It seems to work fine in https://developers.google.com/speed/pagespeed/insights/.
    – Trebor
    Aug 31 '20 at 19:58
  • Pagespeed does not include accessibility metrics, use Lighthouse from Chrome dev tools. Sep 1 '20 at 5:20
  • Questions that only could apply to your site are considered off-topic here since sites can change and become unavailable in the future.
    – dan
    Sep 1 '20 at 7:39
1

Your page is having "Translate this page" issue and Google is showing it for the both links which are indexed in Google. You need to fix that. For more info related to that, follow this post https://webmasters.stackexchange.com/questions/5043/how-can-i-prevent-google-mistakenly-offering-to-translate-a-page[![enter image description here]1]1

3
  • It's no issue, <html lang="ru">. That's why "Translate this page" is showing. Sep 1 '20 at 5:17
  • This is a multilingual issue. You should use this <link rel="alternate" href="example.com" hreflang="es-es" /><link rel="alternate" href="example.com/fr" hreflang="fr-fr" /><link rel="alternate" href="example.com/pt" hreflang="pt-pt" /> instead of html lang tag. If a user finds your content in English language based country and they see Russian language, users will try to translate the content using browser's inbuilt translate this page option provided. Those clicks on the "translate this page" brings the same thing in the SERPs as well.
    – Rajat
    Sep 1 '20 at 5:27
  • The issue is closed, as expected, the problem was in the code highlighter, namely, the code tag was needed inside the pre tag. For some unknown reason, when setting the width of the pre tag or the entire article, Googlebot gave an error, if there was a code wrapper, this problem did not arise. The default nuxt / markdownit highlighter is installed, everything is in order, the page is in the index. Maybe someone else will face such a problem and find the answer. Sep 1 '20 at 9:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.