1

I am running apache2 on Linux Mint Debian Edition 4.0. I am an apache newbie. I have setup a virtual host to point to my url. I am using dynu.com for virtual DNS redirection using the ddclient program to update dynu. When I try to bring up my url (markmhart.com) in any browser, instead of my index page I get the router configuration page. The webDAV configurations I have setup in the virtual host don't work. Here is my virtual host definition:

<VirtualHost *:80>
        ServerName markmhart.com
        ServerAlias www.markmhart.com www.markmhart.us markmhart.us
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/markmhart.com/web/html
        <Directory "/">
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/markmhart.com/web/html/>
                Options Indexes MultiViews FollowSymLinks
                AllowOverride All
                Order allow,deny
                allow from all
                Require all granted
        </Directory>

        Alias /webdav /var/www/markmhart.com/web

        <Location /webdav>
                DAV On
                Options Indexes MultiViews FollowSymLinks
                AuthType Basic
                AuthName "webdav"
                AuthUserFile /var/www/markmhart.com/passwd.dav
                Require valid-user
        </Location>

        Alias /media /media/mark/media

        <Location /media>
                DAV On
                Options Indexes MultiViews FollowSymLinks
                AuthType Basic
                AuthName "media"
                AuthUserFile /var/www/markmhart.com/passwd.dav
                Require valid-user
        </Location>
        
        Alias /music /media/mark/Music

        <Location /music>
                DAV On
                Options Indexes MultiViews FollowSymLinks
                Order allow,deny
                allow from all
                require all granted
        </Location>

        ErrorLog /var/log/apache2/markmhart.com-error.log
        LogLevel warn
        CustomLog /var/log/apache2/markmhart.com-access.log combined
        ServerSignature On

</VirtualHost>

I did a wget --spider with the following results:

wget --spider -S markmhart.com
Spider mode enabled. Check if remote file exists.
--2020-08-02 14:32:37--  http://markmhart.com/
Resolving markmhart.com (markmhart.com)... 47.156.192.189
Connecting to markmhart.com (markmhart.com)|47.156.192.189|:80... 
connected.
HTTP request sent, awaiting response... 
  HTTP/1.1 200 OK
  Content-Type: text/html; charset=UTF-8
  Cache-Control: no-store, no-cache, must-revalidate, post-check=0, 
  pre-check=0
  Pragma: no-cache
  CONTENT-LANGUAGE: en
  Date: Sun, 02 Aug 2020 21:32:37 GMT
  Server: lighttpd/1.4.39
Length: unspecified [text/html]
Remote file exists and could contain further links,
but recursion is disabled -- not retrieving.

I don't know why it is showing lighttpd as the server - I'm using apache2, and lighttpd has never been installed on this particular computer, unless the router itself is using lighttpd (Linksys AC5400 - EA9500).

My HOSTS file:

127.0.0.1   localhost markmhart-com
192.168.1.105   markmhart.com www.markmhart.com markmhart.us www.markmhart.us jenniahart.com www.jenniahart.com
# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback   
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters 
ff02::3 ip6-allhosts

I tried installing DNS server but have equivalent results. Web page and DAV data work on local machine, but router configuration page shows up on others. Do I need to alter settings in my router?

Thanks in advance for your help.

  • Do you have your router configured to forward port 80 to your host computer/server's IP address? The same would be necessary for port 443 if you're planning on serving HTTPS. – dan Jul 30 at 6:53
  • For the same reason this was closed on Server Fault here, we really would need more details in order to be able to answer this. – dan Jul 30 at 8:39
  • Can ypu giveme a hint as to what additional details you want? I've tried to be as clear as possible about my needs in this post. Thank you. – user3670606 Jul 30 at 19:51
  • A good place to start would be with my first comment above, and then as suggested on Server Fault, edit in the output from wget --spider -S markmhart.com. If your router page is being displayed that means requests are going to that instead of your computer/server. The same would be true of requests from outside your network - if they're not being accepted by your router, then you need to make sure the ports are being forwarded properly. – dan Jul 31 at 0:14
  • 1
    Sorry for the lack of communication. I'm in the middle of a system crash on markmhart.com, and I'm still trying to shake out the problems after upgrading my router to openwrt. When I'm back up and have the router working, I'll forward port 80 as requested. Thanks again for your help! – user3670606 Aug 5 at 0:57

Browse other questions tagged or ask your own question.