We've got a page that embeds a .MOV file into a webpage. In the last 6 months it stopped working on some Macs. Then it stopped working on all macs. Then it stopped working on Windows XP. But it works fine in Windows 7. Here's what is embedded in the HTML:

<embed src="/Magic94Scripts/mgrqispi94.dll?APPNAME=FileManager&PRGNAME=prjfilmview&ResID=2784&size=9" style="float: left;" height="600" width="1030">

This has worked perfectly for years. The QuickTime player pulls the file out of the requester, inspects the MIME type from the response headers and plays the file appropriately. A Wireshark dump from a Windows 7 looks like this:

Quicktime Windows 7 dump http://goodoil.enets.com.au/QuickTime-Win7.png

  1. The intial request for the page that has the <embed> tag in it
  2. The QuickTime plugin requesting the MOV file through the back-end requester

Performing the exact same actions on OSX or Windows XP wields:

Quicktime XP-OSX dump http://goodoil.enets.com.au/QuickTime-XPOSX.png

The versions of quicktime and safari on all the different machines is the latest (5.0) and I assume this is something that was broken in an update, and as our clients moved to the newer version of the browser they were breaking one by one.

Any ideas what might cause this? Is this a bug in Safari? Are there better ways of embedding the MOV file?

  • Do you still have those images? The domain is down. I tried to rehost them to imgur, but the Wayback Machine on Archive.org has no record of them either.
    – TRiG
    Jun 2, 2015 at 14:44
  • @TRiG Just had a search, they're long gone I'm afraid. That project was decommissioned over 4 years ago as well, so any archives I had are gone too. Jun 2, 2015 at 21:13

2 Answers 2


I have solved the situation by doing URL ReWriting with the following rule:

RewriteRule (/res/)(.*)/(.*)/(.*)/(.*) /Magic94Scripts/mgrqispi94.dll?APPNAME=$2&PRGNAME=ViewResource&ResID=$3&size=$4 [I,O,U]

And using URLs such as:


Crazy, but it now works. I can only assume quicktime now only inspects the URL for the filetype, rather than grabbing the content-header.


You might try specifying the type attribute check out http://www.quackit.com/html_5/tags/html_embed_tag.cfm for more detail.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.