1

I have a domain name with some existing sub-domains that work. I mean I can ping them and access them via https protocol. Now I want to add another one and it does not propagate, meaning I cannot ping it from several computers and http/https are not working either.

I wait two weeks, so propagation shall be done already. domain name is: cuddlup.fr old working subdomain: chopemoiparis.cuddlup.fr new non-working subdomain: matlimoges.cuddlup.fr

I have created for both a A record in my Azure DNS with 1 hour TTL. Only difference I see is that the new server is not always up and the new IP is fixed (which was not the case before but I have an update script running every 10 minutes).

Testing the DNS with external tools show it is not known. https://www.digwebinterface.com/ shows two different output for them:

The working one:

chopemoiparis.cuddlup.fr@8.8.4.4 (Default):  Copy results to clipboard
.           81938   IN  NS  m.root-servers.net.
.           81938   IN  NS  b.root-servers.net.
.           81938   IN  NS  c.root-servers.net.
.           81938   IN  NS  d.root-servers.net.
.           81938   IN  NS  e.root-servers.net.
.           81938   IN  NS  f.root-servers.net.
.           81938   IN  NS  g.root-servers.net.
.           81938   IN  NS  h.root-servers.net.
.           81938   IN  NS  a.root-servers.net.
.           81938   IN  NS  i.root-servers.net.
.           81938   IN  NS  j.root-servers.net.
.           81938   IN  NS  k.root-servers.net.
.           81938   IN  NS  l.root-servers.net.
;; Received 228 bytes from 8.8.4.4#53(8.8.4.4) in 20 ms

fr.         172800  IN  NS  e.ext.nic.fr.
fr.         172800  IN  NS  f.ext.nic.fr.
fr.         172800  IN  NS  g.ext.nic.fr.
fr.         172800  IN  NS  d.nic.fr.
;; Received 290 bytes from 192.58.128.30#53(192.58.128.30) in 24 ms

cuddlup.fr.     172800  IN  NS  ns1117.ui-dns.org.
cuddlup.fr.     172800  IN  NS  ns1032.ui-dns.de.
cuddlup.fr.     172800  IN  NS  ns1026.ui-dns.com.
cuddlup.fr.     172800  IN  NS  ns1098.ui-dns.biz.
;; Received 165 bytes from 194.146.106.46#53(194.146.106.46) in 26 ms

chopemoiparis.cuddlup.fr. 3600  IN  NS  ns1-05.azure-dns.com.
chopemoiparis.cuddlup.fr. 3600  IN  NS  ns2-05.azure-dns.net.
chopemoiparis.cuddlup.fr. 3600  IN  NS  ns3-05.azure-dns.org.
chopemoiparis.cuddlup.fr. 3600  IN  NS  ns4-05.azure-dns.info.
;; Received 179 bytes from 217.160.81.98#53(217.160.81.98) in 21 ms

chopemoiparis.cuddlup.fr. 3600  IN  A   93.19.120.83
;; Received 58 bytes from 13.107.24.5#53(13.107.24.5) in 34 ms

and the non-working one:

matlimoges.cuddlup.fr@8.8.4.4 (Default):  Copy results to clipboard
.           30797   IN  NS  a.root-servers.net.
.           30797   IN  NS  b.root-servers.net.
.           30797   IN  NS  c.root-servers.net.
.           30797   IN  NS  d.root-servers.net.
.           30797   IN  NS  e.root-servers.net.
.           30797   IN  NS  f.root-servers.net.
.           30797   IN  NS  g.root-servers.net.
.           30797   IN  NS  h.root-servers.net.
.           30797   IN  NS  i.root-servers.net.
.           30797   IN  NS  j.root-servers.net.
.           30797   IN  NS  k.root-servers.net.
.           30797   IN  NS  l.root-servers.net.
.           30797   IN  NS  m.root-servers.net.
;; Received 228 bytes from 8.8.4.4#53(8.8.4.4) in 20 ms

fr.         172800  IN  NS  d.nic.fr.
fr.         172800  IN  NS  f.ext.nic.fr.
fr.         172800  IN  NS  g.ext.nic.fr.
fr.         172800  IN  NS  e.ext.nic.fr.
;; Received 287 bytes from 192.36.148.17#53(192.36.148.17) in 68 ms

cuddlup.fr.     172800  IN  NS  ns1098.ui-dns.biz.
cuddlup.fr.     172800  IN  NS  ns1026.ui-dns.com.
cuddlup.fr.     172800  IN  NS  ns1032.ui-dns.de.
cuddlup.fr.     172800  IN  NS  ns1117.ui-dns.org.
;; Received 162 bytes from 194.146.106.46#53(194.146.106.46) in 79 ms

cuddlup.fr.     600 IN  SOA ns1117.ui-dns.org. hostmaster.1und1.com. 2017060103 28800 7200 604800 600
;; Received 112 bytes from 217.160.83.117#53(217.160.83.117) in 16 ms

What am I missing?

Thank you

0
3

First, there is no DNS "propagation" as the protocol does not handle updates top down.

Any change should appear immediately on the authoritative nameservers, and will appear on recursive depending on their cache and the TTL on records.

If you go to https://dnsviz.net/d/matlimoges.cuddlup.fr/XuGt4g/dnssec/ you can see that your domain matlimoges.cuddlup.fr is an NXDOMAIN: authoritative nameserver are replying it does not exist, hence they are not configured properly.

Easy to dig(!) the same information:

1) finding the authoritative nameservers:

$ dig matlimoges.cuddlup.fr NS

[..]

;; AUTHORITY SECTION:
cuddlup.fr.     10m IN SOA ns1117.ui-dns.org. hostmaster.1und1.com. (
                2017060103 ; serial
                28800      ; refresh (8 hours)
                7200       ; retry (2 hours)
                604800     ; expire (1 week)
                600        ; minimum (10 minutes)
                )

No reply, so we go one step above:

$ dig cuddlup.fr NS

[..]


;; ANSWER SECTION:
cuddlup.fr.     12h IN NS ns1032.ui-dns.de.
cuddlup.fr.     12h IN NS ns1117.ui-dns.org.
cuddlup.fr.     12h IN NS ns1098.ui-dns.biz.
cuddlup.fr.     12h IN NS ns1026.ui-dns.com.

2) Now we can ask the above nameservers what they think of your name:

$ for ns in $(dig cuddlup.fr NS +short); do echo $ns; dig @$ns matlimoges.cuddlup.fr A |grep status: |tail -1; done
ns1117.ui-dns.org.
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 4033
ns1032.ui-dns.de.
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 17284
ns1026.ui-dns.com.
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 15846
ns1098.ui-dns.biz.
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 64942

As you can see all 4 reply "NXDOMAIN", which means the name matlimoges.cuddlup.fr does not exist (in the zonefile, hence in the global DNS).

For comparison with the other working name:

$ for ns in $(dig cuddlup.fr NS +short); do echo $ns; dig @$ns chopemoiparis.cuddlup.fr A |grep status: |tail -1; done
ns1032.ui-dns.de.
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24853
ns1098.ui-dns.biz.
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37792
ns1026.ui-dns.com.
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40683
ns1117.ui-dns.org.
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43928

Solution: configure those 4 nameservers correctly to resolve the name you need. You shouldn't wait: there is nothing that will heal itself, there is a configuration problem (first step to double check: did you remember to update the serial after any change in the zonefile? Based on the serial value that follows the usual YYYYMMDDXX format, I am pretty sure you forgot to update it).

1
  • Thank you Patrick, I was not aware of the serial field. In order to update it in azure, the SOA record has to be edited. I incremented it, but still the subdomain is not visible, so I believe I need to change the parent zone as well.
    – Christophe
    Jun 11 '20 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.