0

I have a google site and I have a domain. The domain is registered with GoDaddy and points to DreamHost (I host other sites on this DH account so it is not dedicated for this site). Because it's a google site, the Dreamhost domain just has index.html which redirects to the google site:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
    <HEAD>
    <META http-equiv="REFRESH" content="0;url=https://sites.google.com/view/.../home"></HEAD>
    <BODY>
        Redirecting...
    </BODY>
</HTML>

However, this does not show the domain. To accomplish that, I need to verify the domain ownership:

enter image description here

But when I click "verify your ownership," the subsequent verification process instructions are confusing. The verification process asks "who is your domain provider?"

enter image description here

I assume by "domain provider" it means registrar, because GoDaddy is on the list and DreamHost is not. However, the subsequent instruction says to add a TXT record to the domain:

enter image description here

This option is available in DreamHost, but not in GoDaddy:

GoDaddy domain DNS console (no TXT record option present): enter image description here

DreamHost console (TXT option present): enter image description here

But when I add the TXT record in Dreamhost, waited days for it to propogate, I get this error in google sites:

Verification failed for www.********.org using the DNS TXT record method (less than a minute ago). Your verification DNS TXT record was not found. You might need to wait a few minutes before Google sees your changes to the TXT records.

How do I proceed?

Note: I would prefer to keep DreamHost as the domain manager for the sake of email, but it is not that important. If I need to cut DreamHost out of this loop that is ok.

  • Since you're using DreamHost nameservers, DreamHost is definitely the place to add that TXT record. Make sure you're adding TXT to www as Google wants, not to the bare domain. – Maximillian Laumeister May 1 at 18:36
  • Wow! The missing www was the key! Thanks. Leave it as an answer and I'll give the check mark – ryvantage May 2 at 13:51
  • Awesome. Thanks! – Maximillian Laumeister May 2 at 17:02
1

Make sure you're adding your TXT record to www as Google wants, not just to the bare domain.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.