3

I have 2 servers both running Ubuntu 18-04:

  • server A with apt install of jitsi-meet (fully working)
  • server B with an edited install (from github) of jibri (fully working)

The A server (the server with meet) has a DNS name registered under GoDaddy and is using a GoDaddy certificate for subdomains. Everything seems to work. No problems with trusting SSL in any browser except the android app.

I read in Jitsi Community and elsewhere on the internet that this kind of problem is caused by not fully working certificate. When I check for the SSL on my domain with the Digicert verification tool, there is one voice that I think is not good for android app (TLS Certificate is not trusted).

What I tried

For testing I bought and generated a new SSL cert and tried to use the new one in Prosody configuration. I also had to change the owner on the new files as prosody log reported an error in reading those files (chown prosody:prosody -R directory) and, finally, on prosody log there were no more errors.

I also tried to renew godaddy’s certificate and do the same things as above. I also concatenated all cert files in one.Finally i tried to configure that new (buyed) certificate on a fresh nginx install (on port 8443) and it works (only on nginx).

Results

On android I’m able to join a room on my server A only by using chrome in “desktop version”; within the app it seems impossible as it get disconnected after selecting the room.

There is another strange thing (for me): after changing certificate and certificate authority in prosody domain config, after restarting prosody and jicofo and meet services, verifications on digicert (also by showing up certificates on chrome/firefox/edge), the certificate authority does not change (continuing to show godaddy and not the new one, Sectigo).

So, when I go to my.example:443, certificate is by GoDaddy (but in prosody i changed them...) and on my.example:8443 certificate is by Sectigo. Both the servers (jitsi on 443 and nginx on 8443) have the same .crt and .key in their configuration.

Is there something that I’m doing wrong or something I can do at this point?

Please let me know if you need more infos and really thank you to anyone who can spend some time in helping me with this issue.

EDIT I’m not using nginx nor apache on the servers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy