1

I will start this by saying that I am educated as a mechanical engineer, working as a Control Systems Engineer (electrical engineering) and I've been tasked with setting up a Web Server for a company intranet using MediaWiki. Right now I'm in just the development phase, and the server is currently Apache v2.4 running on my laptop. I need to allow other people in my department to access the server and edit the wiki, so they are accessing via my IP address and port number to get to the file directory currently, but any time they go to make edits, it redirects them to localhost, which obviously causes problems since it's not directed towards my ip address. I've tried setting up vhosts but everything I try fails, even after editing their PC's hosts file.

The following is what I believe to be all the relevant info from my Apache httpd.conf

Define SRVROOT "C:/xampp/apache"
ServerRoot "C:/xampp/apache"

Listen 640

ServerName localhost:640

<Directory />
    AllowOverride none
    Require all denied
</Directory>

DocumentRoot "C:/xampp/htdocs"

<Directory "C:/xampp/htdocs">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Require all granted
</Directory>

Include conf/extra/httpd-vhosts.conf

And I have done multiple attempts with the httpd-vhosts.conf file, but this is the current state of affairs

<VirtualHost MY_STATIC_IP_ADDRESS:640>
    ServerAdmin MY_EMAIL_ADDRESS
    DocumentRoot "C:/xampp/htdocs/MediaWiki/index.php"
    ServerName CompanyIntranet.org
</VirtualHost>

On my coworkers PC, connected on the same LAN network, I added this line (and have tried several variations of IP address with and without port number) to the C:\Windows\System32\Driver\etc\hosts

MY_STATIC_IP_ADDRESS:640 CompanyIntranet.org

I'm starting to run out of ideas to try, and haven't been able to find much help by searching StackExchange or Apache documentation, everything appears to be telling me to do the same stuff I've already tried.

Anytime I have a Listen 80 Apache is unable to start, I changed the port to 640 early to get the server running in the first place.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.