3

My Google Analytics -> Acquisition -> Search Console Data is always empty. I went through this answer, but it doesn't stats my problem.

There are two properties registered in Search Console:

  • One is domain property which is example.com
  • Another is with http which is http://example.com

My all search console data is collected in example.com

When I tried to connect property in Google Analytics -> Admin -> Property -> Property Settings -> Scroll down to search console -> Adjust Search Console then I can see the property with http://example.com is already linked.

Since there is no data collected in http://example.com I cannot see search console data in Google Analytics Report.

So ideally, I should delete the linked property http://example.com and connect property example.com to see all data. However, when I do this, I cannot see URL of website example.com on the configuring search console data in Analytics page

I guess this is because Google automatically links search console web property with our Google Account.

So what should I do in this case? How can I connect the correct property to Google Analytics account? If I delete property http://example.com then will it work? If I delete then how to make a new connection to example.com?

1
3

A verified Domain property in GSC, cannot be linked to GA.
A Domain property is kind of like a "catch all" for www, non-www, https, http, the main domain, any subdomains and even ftp.

Since there is no data collected in http://example.com I cannot see search console data in Google Analytics Report.

So ideally, I should delete the linked property http://example.com and connect property example.com to see all data. However, when I do this, I cannot see URL of website example.com on the configuring search console data in Analytics page

Sounds like you may have created and verified the wrong website url for the URL-prefix property in GSC.

If that is the case:

  1. If you have already linked GA to GSC property http://example.com, delete the link between the two.
  2. In GSC, add a new URL-prefix property for the correct website url and verify it.
  3. Then use the new URL-prefix property to link to GA.

The newly verified URL-prefix property may take a few days to start collecting data in GSC, this is normal, once it does start to report data, you will then be able to also see that data in GA in the Search Console reports.

3

All the above didn't work for me...
What did do the job is to remove the property from search console and re-add it again as a URL Prefix, so:

  1. goto GSC -> Settings -> REMOVE PROPERTY

Remove Property from GSC

  1. re-add property as URL Prefix

Re-link as URL Prefix

  1. goto GA -> property settings -> Search Console -> Adjust Search Console You will see your property there, just choose it...

Link property

Done

1
  • Alright. Thanks for inputs. – Bhargav Joshi Aug 12 '20 at 9:49
1

It's not possible to see from this screen, but it sounds like you have your Search Console Settings in Analytics misconfigured.

Try this:

  • Sign in to your Analytics account.
  • Click Admin, and navigate to the property in which you want to enable Search Console data sharing.
  • In the PROPERTY column, click Property Settings.
  • Scroll down to Search Console Settings. You should see the URL of your website, which confirms that the website is verified in Search Console and that you have permission to make changes. If you do not see the URL, you need to add your site to Search Console. MAKE SURE THIS PROPERTY MATCHES THE PROPERTY NAME IN THE SEARCH CONSOLE. **
  • Under Search Console, select the reporting view(s) in which you want to see Search Console data.
  • Click Save.

** A common mistake in this regard is to associate the "www" or non-www domain in Analytics and the opposite in Search Console. This disparity would lead to no data being visible in Analytics.

3
  • But that is the issue. I cannot see the website. That's why I wrote this question – Bhargav Joshi Feb 26 '20 at 8:28
  • What to do if the property is not matching with the property name in search console? Which is the another way to connect the right property with search console? – Bhargav Joshi Feb 26 '20 at 8:29
  • @Bhargav.. when you visit your website via browser, what is the website url in the browser address bar? If you are using chrome browser, please actually click in the browser address bar to reveal the full url as chrome has started hiding the protocol and the www's. When you visit the website is it https:// example.com or https:// www.example.com or http:// example.com or http:// www.example.com? If you have added and verified the "wrong" prefix url property in GSC, then that GSC property will not have any data in it. support.google.com/webmasters/answer/34592?hl=en – Bronwyn V Feb 26 '20 at 10:39
1

I asked the same question in Google Search Console Community. Here is the right answer link: https://support.google.com/webmasters/thread/31440703?hl=en&msgid=31459111

All I need to do is:

  1. Create a new property in Google Search Console with https://example.com
  2. then de-link the example.com domain property from Google Analytics
  3. and again link the new https://example.com property in Google Analytics.

No data is lost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.