0

TL;DR

The most important links are the following;

  • /reserveren (aka book now page)
  • /veelgestelde-vragen (aka FAQ page)

but not appearing in Google search results


I’m currently optimising my SEO for my website. But I don’t get any blue buttons like my competitor (see the image, I removed all the text because else I advertise here).

Google search result

SiteLink Searchbox (microdata): I guess that the blue buttons are SiteLinks I added the following:


<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://site-url.com/",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://site-url.com/faq/{search_term_string}",
    "query-input": "required name=search_term_string"
  }
}

</script>

But that seems to be a search box? Are those blue buttons breadcrumbs then or should I add something else to my code? To get blue buttons in the search result?

Navigation: Code inside my nav element:

    <div class="w-full block flex-grow md:inline-block md:w-auto hidden">
        <a href="/reserveren" class="classes">Reserveren</a>
        <a href="/#het-verhaal" class="classes">Het verhaal</a>
        <a href="/#wat-ga-je-doen" class="classes">Wat ga je doen?</a>
        <a href="/#voor-wie" class="classes">Voor wie?</a>
        <a href="/#prijzen" class="classes">Prijzen</a>
        <a href="/veelgestelde-vragen" class="classes">Veelgestelde vragen</a>
        <a href="/#contact" class="classes">Contact</a>
    </div>

Sitemap:

<?xml version="1.0" encoding="UTF-8"?>
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
    <url>
        <loc>https://my-site.com/</loc>
        <lastmod>2020-02-01</lastmod>
        <changefreq>monthly</changefreq>
        <priority>1</priority>
    </url>
    <url>
        <loc>https://my-site.com/reserveren</loc>
        <lastmod>2020-02-01</lastmod>
        <changefreq>monthly</changefreq>
        <priority>1</priority>
    </url>
    <url>
        <loc>https://my-site.com/veelgestelde-vragen</loc>
        <lastmod>2020-02-01</lastmod>
        <changefreq>monthly</changefreq>
        <priority>1</priority>
    </url>
    <url>
        <loc>https://my-site.com/#welkom</loc>
        <lastmod>2020-01-31</lastmod>
        <changefreq>monthly</changefreq>
        <priority>2</priority>
    </url>
    <url>
        <loc>https://my-site.com/#het-verhaal</loc>
        <lastmod>2020-01-31</lastmod>
        <changefreq>monthly</changefreq>
        <priority>2</priority>
    </url>
    <url>
        <loc>https://my-site.com/#wat-ga-je-doen</loc>
        <lastmod>2020-01-31</lastmod>
        <changefreq>monthly</changefreq>
        <priority>2</priority>
    </url>
    <url>
        <loc>https://my-site.com/#voor-wie</loc>
        <lastmod>2020-01-31</lastmod>
        <changefreq>monthly</changefreq>
        <priority>2</priority>
    </url>
    <url>
        <loc>https://my-site.com/#prijzen</loc>
        <lastmod>2020-01-31</lastmod>
        <changefreq>monthly</changefreq>
        <priority>2</priority>
    </url>
    <url>
        <loc>https://my-site.com/#contact</loc>
        <lastmod>2020-01-31</lastmod>
        <changefreq>monthly</changefreq>
        <priority>2</priority>
    </url>
</urlset>
0

Those blue buttons are indeed site links. I believe if you do your internal linking from the home page correctly, and if you set your priorities in the sitemap correctly, you should also start seeing them.

| improve this answer | |
  • I added extra information to my question like navigation code and sitemap. I guess based on your answer that possibly my navigation is incorrect? – Davy de Vries Feb 25 at 8:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.