1

I forwarded my domain to my IP address using google domain. I can access my website using https://my.domain or https://www.my.domain but if I don’t add https:// to start the address like my.domain or www.my.domain, I can’t get my domain redirected. Currently google has two A records (@ and www) automatically set up me.

1

This means that your web server is not accepting connections over http (port 80). You'll need to configure your server to accept these and redirect (forward) them to https.

On a second note I think the terminology is getting a little confused here, and it's important to get it straight because it's the same terminology your registrar and hosting company will use. It looks like ryanc.studio's DNS is already pointed at your server's IP using A records, so now the trick is to make sure that your server is set up to forward http://www.ryanc.studio and http://ryanc.studio to https://ryanc.studio using HTTP permanent (301) redirects.

Setting up the forward is something that I recommend doing directly on the server (or directly in your hosting control panel) for simplicity. The process of actually setting up forwarding will differ depending on what type of control panel your server uses, or if you're hosting without a control panel, the actual server software (nginx, apache, etc.)

| improve this answer | |
  • 1
    Turns out it’s because I forget to allow port 80 on my router’s firewall. Thank you so much. – ryanC_1995 Feb 1 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.