2

I have one custom PHP website and an integrated Wordpress blog with the website. When I publish any blog on the website, Ahrefs treats that blog as orphan pages. I have done interlinking all the blog with one blog to another blog also I have added outbound links, our main services pages links as well.

I have created two separate XML sitemaps just because my main website is PHP and the blog is WordPress. I have submitted 2 sitemaps on the search console.

My concern is why do my website increase orphan pages day by day? How can I solve these issues?

enter image description here

I have attached screenshot of Ahref.com. I have found more than 120 links that SERP treats as orphan pages enter image description here

I've updated blog category and category tag pages (noindex, follow), but ir is still showing the same errors. a screenshot provided below:

  • Sitemaps don't help that much with orphan pages. Including them in a sitemap will get them crawled but search engines usually choose not to index orphan pages. Even when they are indexed, they tend not to rank well. See The Sitemap Paradox – Stephen Ostermiller Jan 7 at 12:07
  • I'm surprised to hear that this could be a problem with a WordPress blog. WordPress usually links new posts from the blog home screen. WordPress also uses categories and tagging that create places that all posts get links. Have you disabled all those features or something? – Stephen Ostermiller Jan 7 at 12:11
  • 1
    Yes, I have disabled category, tagging and some features in WordPress because to avoid duplication. – Olivia Jan 7 at 12:27
  • 1
    Site maps are not the same as links. You'll actually need to create links to the pages not just create site maps. See The Sitemap Paradox – Stephen Ostermiller Jan 7 at 13:08
  • 1
    I don't see a reason why you would disable categories. There should be some way that your blog posts are grouped together. By grouping them into categories, you would allow SEs to better understand your blog structure, and reduce the "click depth", and then those pages will not be seen as orphans. What you can do is, add "noindex" to your category pages, if you are scared of duplicate content. – Mnea Jan 7 at 20:28
1

Don't overthink it. Your blog pages (articles) should be linked on:

  • Main blog page (index, follow)
  • Blog category page (noindex, follow)
  • Blog tag page (noindex, follow)
  • PHP website pages, where they match the content (index, follow)

You see, despite some pages are noindex, all of them are follow - this is because even pages not worth for index are crawled by Googlebot and should help Googlebot discover new urls.

PS: Sitemaps play no role in the matter of:

  • indexing
  • internal linking
  • Thank you for the clarification. I have updated the blog category and category tag pages (noindex, follow), but it is still showing the same errors. I have attached another screenshot above, please have a look and do let me know how can I fix these error? – Olivia Jan 9 at 5:44
  • Look at the date of the last Ahref crawl. Maybe their bot wasn't yet on your site after change. – Evgeniy Jan 9 at 11:19
  • According to Ahref, the bot last crawled on Jan 8, 2020, but I changed it on October last year. – Olivia Jan 9 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.