2

My home is armed with a DIR-868L D-Link router and I am trying to host a website from my PC behind it on the local IP 192.16.0.198 port 32768 (which I can configure).

I tried configuring port forwarding and/or a 'virtual server' on my router, where the 'virtual server' approach seemed to do something. When configuring it for external port 80, to my internal IP and (arbitrary) port 32768, I could access a simple website from inside the LAN over the external IP (in a browser)..., but I cannot access it over WAN using the external IP.

Hosting basic webpage using python -m SimpleHTTPServer 32768

Virtual server config: virtual server configuration

When browsing to my external IP using 4g (by phone), I am entering the router configuration page. When doing the exact same over wifi (by laptop), I enter the site, as intended.

question

How can I make my router pass through port 80 communication to my specific PC behind the router, so that my external IP would result in my website when approaching it over WAN?

Might it magically work when starting to use an SSL certificate and communicate over the HTTPS port 443? It does seem that the router does only serve an HTTP (80) config page...

It has only been for 3 days that I have tried to fix this and thought myself some networking skills, so I am very open to suggestions or lessons.

(As a side note, I already have a domain and an A-record DNS is currently directing my domain to my external IP)

edit

Addition on @Kevin Mason's answer: I could now confirm that being able to remotely access the router config (which is a feature that can be configured in the router) was causing the port 80 (web browser access) to be intercepted. The setting is a bit hidden in 'Management' -> 'admin settings' -> 'advanced settings' -> 'Remote management', disable this to be able to host a website.

2

When browsing to my external IP using 4g (by phone), I am entering the router configuration page. When doing the exact same over wifi (by laptop), I enter the site, as intended.

It sounds like you have enabled the router config page to be accessed both internally and externally. External access to the config is a very bad idea and is most likely on the same port you are setting up the port forward on. You need to disable the external access for the config page asap, then try the port forward.

|improve this answer|||||
  • Thanks Kevin! You share my thinking, I looked for such an option but couldn't find it, do you have any idea how that property could be called? Or could this be done by incorrect port forwarding? – Siete Jan 5 at 14:33
  • 2
    Referring to the user manual on page 97 eu.dlink.com/-/media/consumer_products/dir/dir-868l/manual/… you need to disable remote mamagement Remote management allows the DIR-868L to be conigured from the Internet by a web browser. A username/password is still required to access the Web Management interface. – Kevin Mason Jan 5 at 15:46
  • Another thought, what internal IP address is the port forwarding pointing to and on what port? it should be pointing to the webserver – Kevin Mason Jan 6 at 0:19
  • I got it working!! I found the 'disable remote management' at 'admin settings' -> 'advanced settings', disabling it made it instantly work. Remaining config: using 'virtual server' (when using 'port forwarding', it could not be configured with a different internal port), communicating port 80 -> 32768. Also port forwarding is configured to open up port 80 for TCP and UDP for my internal IP. Guess lots of different approaches work here, depending on your setup. Thanks for your time Kevin! – Siete Jan 6 at 9:45
  • You are very welcome – Kevin Mason Jan 6 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.