1

I believe my website was hacked. When I run a page through the google data structured testing tool, I get a spammy version of my page. The first thing I did was to restore the site from a backup from before the hack. Afterwards, I located some malicious looking files on my server which I have since deleted. I then contacted my hosting provider, they did a scan on my site, and I was told that there were no problems with the site and everything was clean.

However, running another page on the website through the Google Data Structured Testing Tool and using Google Console's Live Test URL Inspection both revealed the spammy HTML.

Accessing the website via a direct link did not throw up the problem. The problem is only in how Google sees the website. Is the problem still with my website? I thought it could have been a google cache problem, but it seems weird for their live test to be caching results.

  • 1
    Let me guess... are you using WordPress? Some attacks are intended to spam Google (googlebot) and work perfectly well for all user traffic. What CMS are you using? Is your software up to date? Check plug-ins, templates, and other 3rd party code for vulnerabilities. You can use nvd.nist.gov/vuln/search to search for vulnerabilities and updates. Cheers!! – closetnoc Nov 11 '19 at 17:01
  • Yes, my WP installation is up to date. I deactivated all the plugins and still have the problem...what should I try next? – OctaviaLo Nov 11 '19 at 17:07
  • 1
    When you restored from backup, did you delete everything from the server first? – GeoffAtkins Nov 11 '19 at 17:22
  • I would add that you may need to delete the contents of the WP database when you delete the contents of the web space. – closetnoc Nov 11 '19 at 17:24
  • No. I restored the backup and then deleted the malicious files. It seems obvious now that you said it but I have tried so many things I've lost track of what I've done. What you are suggesting is to restore from a backup now AFTER I have deleted the malicious files? – OctaviaLo Nov 11 '19 at 17:25
2

Thanks to the comment by @closetnoc and the helpful link to nvd.nist.gov/vuln/search I was able to troubleshoot the problem. The solution is a fresh reinstall of Wordpress on the server (Bluehost helped me with this) and then a backup from VaultPress (If you have VaultPress). Otherwise, manually add the backups, but don't add the core files. Since those were the corrupted files. Just the sql, wp-content, .htaccess, robots.txt and wp-config.php

  • 1
    Sorry - I had to leave for a while. I am glad you got it! And Thanks for sharing your solution. I appreciate it. Cheers!! – closetnoc Nov 11 '19 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.