0

I am currently trying to implement multiple How To schema types to a single page but keep receiving an error (Missing '}' or object member name) when trying to validate my code. Is this possible? Below is the code I have been working with:

<script type="application/ld+json">
{
  "@context": "https://schema.org/", 
  "@graph":
  [
  {
  "@type": "HowTo", 
  "name": "XYZ",
  "description": "XYZ",
  "totalTime": "PT5M",
  "step": [{
    "@type": "HowToStep",
    "text": "ABC"
  },{
    "@type": "HowToStep",
    "text": "DEF"
  },{
    "@type": "HowToStep",
    "text": "GHI"
  },{
    "@type": "HowToStep",
    "text": "KNJ"
  },{
    "@type": "HowToStep",
    "text": "XYZ"
  }],
}
}
{ 
  "@type": "HowTo", 
  "name": "ABC",
  "description": "DEF",
  "step": [{
    "@type": "HowToStep",
    "text": "GHI"
  },{
    "@type": "HowToStep",
    "text": "YUI"
  },{
    "@type": "HowToStep",
    "text": "WER"
  }],
</script>
  • You have multiple errors in your JSON. Are you familiar with the basic syntax rules? The first obvious error is that you start the whole thing with a { (which is correct), but there is no closing } at the end. The same is true for some other brackets. If you open something with a bracket, you need to close it with the corresponding bracket, too. – unor Nov 4 at 20:05
  • I am familiar with the basics but I am new to building the code myself. This is something I am trying to piece together from a template that I found. If you have any resources or advice for trouble shooting this I would really appreciate it. – DenverSEO Nov 4 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.