0

My page, after adding SSL certificate, cannot have preview fetched by Facebook or Twitter when sharing the link. I have followed The Open Graph protocol and include the following open graph tags:

<meta property="og:type" content="article" />
<meta property="og:title" content="Corner Timer: gently make you feel guilty on time-wasting apps" />
<meta property="og:url" content="https://lyminhnhat.com/resources/productivity/corner-timer-gently-make-you-feel-guilty-on-time-wasting-apps/" />
<meta property="og:description" content="Make you feel guilty for your unproductive curiosity" />
<meta property="og:site_name" content="Lý Minh Nhật" />
<meta name="twitter:site" content="@ooker777" />
<meta name="twitter:text:title" content="Corner Timer: gently make you feel guilty on time-wasting apps" />
<meta name="twitter:image" content="https://lyminhnhat.com/wp-content/uploads/2019/04/Screenshot_2019-04-11-11-31-39.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

However, all 3 Open Graph checkers I use - OpenGraphCheck.com, Abhinay Rathore's Open Graph Tester, Facebook's Object Debugger - say that there is no Open Graph implement. There is one exception though: Iframely's Embed Codes

Since all three checkers have problem with this, probably this is not just a problem of of Facebook, as suggested in FB OpenGraph og:image not pulling images (possibly https?). Nevertheless, nothing changes even though I have tried using html links only, stripping end white space, using <html prefix="og: http://ogp.me/ns#">.

This person suggests that this may be a server issue. A misconfiguration, perhaps. Do you know why this happens or how to identify the problem?


Other information:
• SSL certificate: Let's Encrypt
• Control Panel: DirectAdmin
• Server: Nginx
Related: How to know if a problem is a server issue or control panel issue?

  • First https://quảcầu.com does not work properly, because the certificate returned by the server is for name server19.digistar.vn and not your name. So that would be first point to address as any proper HTTPS client will refuse connecting to it. Second you seem to test with https://quảcầu.com/bo-suu-tap-tu-dien-chuyen-nganh/ which for me returns a 404 anyway after I bypass the certificate checks. Third, even if I check the main page, there is no meta tags, as the following returns nothing: wget -O - --no-check-certificate https://quảcầu.com/ | grep meta. – Patrick Mevzek Aug 21 at 17:19
1

It does appear that your server is blocking access by bot sites such as the Open Graph evaluation tools (the site can be access by Google bots such as the Google Structured Data testing tool, but not others). I tried it with the https://lyminhnhat.com/resources/productivity/corner-timer-gently-make-you-feel-guilty-on-time-wasting-apps/ address from your tag.

I was able to see your tags when I temporarily pasted your values into one of my pages and then ran it through a couple of the testers.

  • can you elaborate more on the last paragraph? What are your pages and the testers? – Ooker Aug 20 at 14:57
  • 1
    I have my own website. I verified that one of my web pages would work with two of the Open Graph testers listed in the original post (OpenGraphCheck.com and Abhinay Rathore's Open Graph Tester). I then replaced my working og tags with the tags from the original post and reran my page through the testers. The tags worked. – Rich DeBourke Aug 20 at 21:03
0

Is this your website? https://quảcầu.com

If so those tags are not there, so that's probably why you're having trouble with it.

  • yes, that my website too. But the scrappers still can't read the correctly installed site. It seems that this is an issue from the server, not the sourcecode – Ooker Aug 20 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.