1

Note: I originally asked this on Server Fault and was told it was against the rules for mentioning Webuzo, so please do not ask me to take it there.

System: VPS running CentOS 7 and Webuzo. httpd and sendmail had both been configured, but I wanted to add Roundcube for webmail.

Backstory: I first tried installing Roundcube from the command line. I attempted to follow these instructions but when I put Roundcube in my document root directory, I still got a 404.

I uninstalled the maria-db server and mysql packages, and then went to Webuzo to try to install it there. I was able to locate the installation page but got the error Database is not posted. I was unable to find any explanation of this error. My best guess is a necessary database port is blocked by my firewall, but I have no way to find out what the port number should be.

The problem: This afternoon, I discovered I was getting 404 errors for pages that had previously been accessible. httpd reported that it was unable to run due ot the port already being in use. I killed the process listening on port 80, then ran systemctl start httpd, but that didn't fix anything. Moreover, when that was running, Webuzo reported that the Apache server was actually stopped.

After more investigation, I found there was an extra copy of httpd that was now registered with systemctl. My guess is that something imported with the Roundcube-related packages brought it along. Stopping that and running the Webuzo version restored home-directory Web pages. I had to edit webuzoVH.conf to get my DocumentRoot setting fixed.

My questions:

  1. Can I just delete the directory with the extra httpd? I'm leery of running an uninstall command.
  2. How do I get systemctl back in touch with the correct httpd?
  3. How do I install Roundcube (or any other webmail, at this point), ideally without destroying anything?

closed as off-topic by Stephen Ostermiller Aug 12 at 22:58

  • This question does not appear to be about webmastering within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm voting to close this question as off-topic because it is about server administration. – Stephen Ostermiller Aug 12 at 22:58
  • As the note up top says, I tried asking it as a server administration question first, only to be told it was not allowed there. – pmext Aug 12 at 23:13
  • Just because it isn't allowed there, it doesn't mean it is on-topic here. I would also close this as "too broad" because you ask multiple questions per post. – Stephen Ostermiller Aug 13 at 9:49
  • It's all from the same cause though. Unless I'm mistaken, in which case I would accept an explanation of how I misconstrued two separate things. – pmext Aug 13 at 14:35
  • And if a question about httpd isn't on topic for web administration, where is it on topic? – pmext Aug 13 at 14:40