I'm trying to submit a very simple sitemap (for testing only) to Google Search Console but, unfortunately, I'm constantly receiving the following error message:

║ Sitemap      │ Type    │ Submitted    │ Last read │ Status           │ Discovered URLs ║
║ /sitemap.txt │ Unknown │ Jul 17, 2019 │           │ *Couldn't fetch* │ 0               ║

Clicking on it, there is an additional error message: "(!) Sitemap could not be read".
However, if you click on "OPEN SITEMAP" then it opens normally.

Any idea what is going on?

Website Info

Domain: world-hello.ddns.net
Sitemap File: sitemap.txt
Server: Apache (Debian)

Sitemap in Text Format

According to Google support:

# Sitemap formats   
Google supports several sitemap formats, described here. [...]      

## Text 
If your sitemap includes only web page URLs, you can provide Google with a simple text file that contains one URL per line. For example:


Guidelines for text file sitemaps:

    Encode your file using UTF-8 encoding.
    Your text file should contain nothing but the list of URLs.
    You can name the text file anything you wish, provided it has a .txt extension (for instance, sitemap.txt).

Moreover, I have also tried with XML format and it did not work either.


2 Answers 2


not sure if that may resolve it, but it says you need to Encode your file using UTF-8 encoding. I downloaded your file and checked in the terminal.

file -I sitemap.txt

(Here are some useful tips and tricks working with terminal)

And it says it's not UTF-8 encoded. Perhaps open the file in a text editor and make sure it uses plain & simple UTF-8 encoding.

If that doesn't work, I highly recommend setting up XML sitemaps - as it is worth to the additional information you can pass along. Even for the most straightforward product landing pages, we put XML sitemaps in place instead of text files. (I know that's perhaps what you try to avoid - but it will always be my recommendation)

Please link to your XML sitemap and I will troubleshoot :)

  • > "And it says it's not UTF-8 encoded." There is a heat debate whether there is a difference or not between us-ascii or utf-8, and also whether file correctly guess the encode or not. Take look: Force encode from US-ASCII to UTF-8 (iconv)
    – Mark Messa
    Commented Jul 20, 2019 at 17:21
  • True, but whether there is a debate or not - your text file throws errors - so you better give it a try ;) Commented Jul 20, 2019 at 17:23
  • Said that, I have 'converted' sitemap.txt from us-ascii to utf-8 using a two step procedure. Even so, Google Search Console still returns the 'Couldn't fetch' error message.
    – Mark Messa
    Commented Jul 20, 2019 at 17:24
  • Please, download the file yourself and check whether you are seeing utf-8 encode or not. Let me know your results.
    – Mark Messa
    Commented Jul 20, 2019 at 17:25
  • > "Please link to your XML sitemap and I will troubleshoot" I've just created a XML sitemap file using the online generator link you've posted. Even so, Google Search Console still returns the 'Couldn't fetch' error message.
    – Mark Messa
    Commented Jul 20, 2019 at 17:28

This what I did and it works for me:

  1. Login To Google Search Console
  2. Click on "Sitemaps" on the left panel/Menu
  3. On add a sitemap, enter URL of the sitemap you are trying to index, add a Forward slash "/" just after the last forward slash in the URL (Like this http://example.com//sitemap.xml)
  4. Click on Submit

If you still get an error, repeat without the extra forward slash. Don't worry, even with the extra forward slash, the Google search console will index the right URL!

If you have verified the website in the console as http:// yet the live website had an https://, you must use https://.

Not the answer you're looking for? Browse other questions tagged or ask your own question.