0

I am really fed up now. I am trying to get my xml sitemap to be read in Search Console but for past 1 months it saying it can't be fetched. Every time I submit the index sitemap its submits it with a success status but "Last read status" is about 5 months ago.

After clicking on it to view the other sub sitemaps only three of them are fetched by Google and rest have a status of couldn't fetch.

These are dynamically generated sitemaps in Laravel.

I have also tried manually created sitemap but still "a couldn't fetch" error is returned.

Please help me in rectifying the issue.

enter image description here

enter image description here

  • Maybe your site doesn't have a big enough authority to be crawled more frequently by google. As a side note, based on your screen captures, you are only submitting around 60+ links per sitemap? A sitemap can contain upto 50,000 links on it, and usually not all of them will be scanned. So maybe consolidate everything into a single one, submit it, and see what happens. – Luis Alberto Barandiaran May 31 at 14:57
  • Nothing happened, Same result, Couldn't fetch – tehrijack Jun 26 at 11:25
  • Sitemaps are not very important for SEO so don't worry too much about it. – Stephen Ostermiller Aug 28 at 13:52
1

This is a known bug of Google new search console. I thought there is some issue in my sitemap, so I have regenerated the sitemap and submitted but it throws the same error. If you look on the google forums you'll see tons of people complaining. Experts are saying that its a bug in google new search console. Your sitemap is in fact pending but shows as error for some reason. Just don't resubmit it (it would reset the query). Google must fix this on their end.

Source: https://support.google.com/webmasters/thread/3280971?hl=en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.