2

When I run a Google PageSpeed insights test I get problem reports for various long URLs with query strings for /load.php?debug=.

These problem reports appear for the loading of any webpage whatsoever.

How could I remove these query strings?

8
  • 1
    By not using the site in debug mode?
    – Tgr
    Apr 24, 2019 at 3:19
  • I didn't even know it is in it... Never had a case when a CMS starts in debug mode... I think this should be an answer like "Unlike may CMSs, MediaWiki starts at debug mode". I'll gladly accept (and thumb up for the sharpness).
    – user58733
    Apr 24, 2019 at 14:09
  • Assuming that it is, because I never setted it on debug mode - not that I recall.
    – user58733
    Apr 24, 2019 at 14:15
  • I went through LocalSettings.php and didn't find a debug variable, I also find nothing in special pages.
    – user58733
    Apr 24, 2019 at 14:25
  • It's not in debug mode by default. It can be forced to be by setting $wgResourceLoaderDebug to true or adding debug=1 to the URL.
    – Tgr
    Apr 25, 2019 at 1:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.