0

I am having a few issues uploading my SSL certificate on Google Cloud. It says that "You are not an authorized owner of the domain for this certificate" while I have already validated the property for my http://domain I am currently transferring to Namecheap and I can't use the DNS method (because I have custom nameservers on my current registrar for Google Cloud).

What would be the best thing to do? Thanks a lot for any help you may provide.

webmaster central proof of property

  • Just to clarify, you're talking about an error you're seeing in the Google Cloud interface, or in Google Search Console? For the latter, the site will need to be re-verified under HTTPS, so you'll need to install the certificate first or use the DNS TXT method. If that's a Google Cloud error, then double-check that your certificate was issued to your domain correctly. – dan Mar 27 at 5:45
  • Hi Dan thanks for your reply. I've tried to verify domain ownership via DNS TXT method and it did't work at first. Turned out it took Google Webmaster Central two days to identify their TXT record. It works now. Thanks. – Amokrane T Mar 30 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.