2

I just wanted to check with others as to whether anyone else is having issues with the new(ish) Google search console?

I've had a search and nothing came up, so I wanted to offer up a couple of issues I've had today to see if anyone else has experienced them and/or had a solution.

  1. From the SEMRush dashboard, when trying to connect SC I attempted to add a new user but every time received the following error: "Failed to add user: Unspecified Error
  2. After the above, I bypassed the SEMRush link to add a user manually. When submitting the details, nothing happened (not even a page refresh). I also tried to add another of my GA account email addresses in both of the above steps and the response was the same.
  3. I then deleted the property and re-added it through the New Search console interface. On trying to connect to the property via the Google Analytics for the account, the domain was not visible in the list of options.
  4. I re-added the domain via the old SC interface, attempted the connection again and the domain was in the list....hmmm!!!
  5. I then added the SEMRush access link (to SC) using the old interface and it worked first time....

Has anyone else experienced anything like this? I'm slightly concerned with these issues due to the old interface being phased out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.