1

I am trying to setup a website for my app domain using an Ubuntu/Apache server hosted on Linode and Cloudflare.

The setup works for

www.my.app

but not for just

my.app without the www.

My settings are as follows:

Cloudflare Crypto

  • SSL - Full (strict)
  • Edge Certificates
    • my.app, *.my.app
    • Type Universal
    • 1 SHA 2 ECDSA Certificate
  • Origin Certificates
    • my.app, *.my.app
  • Universal SSL is not disabled

my.app.conf Apache File

<VirtualHost *:443>
  SSLEngine On
  SSLCertificateFile /etc/ssl/certs/my.app.crt
  SSLCertificateKeyFile /etc/ssl/private/my.app.key

  # Admin email, Server Name (domain name), and any aliases
  ServerAdmin just@thisguy.com
  ServerName www.my.app
  ServerAlias my.app

  # Index file and Document Root (where the public files are located)
  DirectoryIndex index.php
  DocumentRoot /home/myapp/code/myapp/public/
  # Log file locations
  LogLevel warn
  ErrorLog  /home/myapp/code/myapp/storage/logs/error.log
  CustomLog /home/myapp/code/myapp/storage/logs/access.log combined

  <Directory /home/myapp/code/myapp/public>
        Options Indexes FollowSymLinks ExecCGI
        AllowOverride All
        Require all granted
  </Directory>
</VirtualHost>

I read elsewhere that ServerName and ServerAlias can be important and I have tried swapping these values and restarting apache without success.

Browser Error Screenshots

Not private Chrome Not private Safari

Certs

The certs appear to be different, I'm not sure how this is possible, but clearly there is something in the config on my server.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.