1

I've set up the Facebook Open Graph meta tags on my site inset.agency, but when I use the Facebook Debugger the image I wish to use isn't displayed — it just picks the second image down on my the homepage (the image I'm testing it on is the top image on the home page of the mountains, but it's picking up the image of the man in glasses instead)?

I've included the og:image:secure_url information necessary for a https:// connection.

I would like to add a specific image to my site soon to be used by Facebook Open Graph, but I can't seem to get it show an image of my choosing?

Any help would be wonderful.

<meta property="og:title" content="Inset — Web Design, Web Apps, Branding and SEO / Social Ads">
<meta property="og:type"  content="business.business">
<meta property="og:url" content="https://inset.agency">
<meta property="og:image:secure_url" content="https://inset.agency/img/mountain3.jpg">
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:description" content="Web design and digital product agency. We cover web apps and websites, branding, and social media campaigns.">
<meta property="og:site_name" content="inset.agency">
0

Tested your site and got:

The 'og:image' property should be explicitly provided, even if a value can be inferred from other tags.

Try changing

<meta property="og:image:secure_url" content="https://inset.agency/img/mountain3.jpg">

to

<meta property="og:image" content="https://inset.agency/img/mountain3.jpg">

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.