0

I've created a google MyBusiness for a customer of mines, but it doesn't let allow reviews to be added. There is no button to "review".

I've tried a few "fix" that I found on the internet such as the "marker wiggle" on the location pane but it didn't seem to change anything. Reading some threads made me think that reviews were tied to a listing, but the listing for my business is 80% completed: "needs a logo". There is a button to add a logo but when I click on it I get to the general "add photo" page, which doesn't allow me to add a logo (there is no corresponding button) ...

Why can't this business receive reviews, could it be tied to the lack of logo and why can't I add a logo?

  • Note: I didn't not provide a link to the described business to avoid my question being flagged as spam (I'm for StackOverflow). Let me know if I should – Mathieu VIALES Feb 11 at 18:00
  • A logo is just a picture. Have you tried uploading it as a photo? – Stephen Ostermiller Feb 11 at 22:27
  • Yup, I tried. Google sees at as plain picture like any other. I looked around on forums and people said to upload the picture under the "identity" tab along with the "cover" picture. I did that, but google moves the newly uploaded image back to the "owner-uploaded" section without recognizing it as an attempt to add a logo ... – Mathieu VIALES Feb 11 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.