1

I've always assumed that if I use an external nameserver (like Cloudflare) for a domain, then my local WHM nameserver is completely bypassed for that domain. Is this correct?

I've always pointed MX records to external services like Office 365 and Gmail, so I'm a little confused as I try to use a local mail account for the first time. Here are the combinations I've tried on Cloudflare - can someone help me understand which one is correct in principle?

  1. An MX record pointing subdomain "mail" to "mail.domain.tld" and an A record pointing subdomain "mail" to my IP address
  2. An MX record pointing subdomain "mail" to "mail.domain.tld" and a CNAME record pointing subdomain "mail" to "domain.tld" (there's always an A record pointing "domain.tld" to my IP address)
  3. An MX record pointing subdomain "mail" to "mail.domain.tld" and no A or CNAME record for subdomain "mail"
  4. An MX record pointing "domain.tld" (@) to "mail.domain.tld" and an A record pointing subdomain "mail" to my IP address
  5. An MX record pointing "domain.tld" (@) to "mail.domain.tld" and a CNAME record pointing subdomain "mail" to "domain.tld" (there's always an A record pointing "domain.tld" to my IP address)
  6. An MX record pointing "domain.tld" (@) to "mail.domain.tld" and no A or CNAME record for subdomain "mail"

Ironically, setting up a CNAME for "webmail" pointing to "@" worked immediately and at least one of the configurations above allowed me to receive mail. It's logging into the server remotely that is giving me trouble.

Thanks!

  • 1
    CloudFlare will indeed bypass your nameservers and DNS settings that you have in cPanel/WHM. Can you clarify (by editing your question) what you're trying to accomplish (e.g., is it just logging into webmail that you're having problems with)? If you're trying to setup MX records for a mail server running on cPanel, then this might help (see "Set up with your own email server"). It will take time for your MX and other DNS records to propagate throughout the Internet, so give it 24-48 hours. – dan Jan 11 at 3:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.