We have a multilanguage Wordpress website with the following subdirectories. https://mca.electricmura.ro/en/ https://mca.electricmura.ro/de/ https://mca.electricmura.ro/ro/

We use the Polylang plugin for multilanguage support. If no language is specified for the homepage, it automatically redirects to the '/en/' homepage. This is a setting in Polylang. The other option would have been to have all the English pages omit the 'en' part. But we went with the homepage redirect and have many Ads using the current links format. There are no redirects for all other pages, since a URL is manually specified for each. Only the homepage needed a tweak.

We recently noticed (and do not know when this started) that Google search returns the En versions of our pages for searches that use Ro keywords. I should add that we are using Google.com and our current location is Romania.

How to replicate: We search for "reparatii CCC" (reparatii means "repairs"). We expect to find on the first page of Google results our webpage which deals with this topis (this is how it used to be many months ago). However, we encounter only the English version of our page This can be replicated with other keywords and other pages from our website.

From the Google Search Console we see that Google successfully crawled the Romanian pages. From the results we get in a search, we can see that Google associated correctly a particular page with a particular Romanian keyword. But when delivering the result, it simply chooses to offer the English version of the page and we can't figure out why. Help is greatly appreciated. Level of proficiency is moderate, so we appreciate your patience.

1 Answer 1


Apparently, the plugin is using redirects together with the hreflangs meta-tags, which can be tricky. If you check your source, you'll find the following meta tags:

<link rel="alternate" href="https://mca.electricmura.ro/en/" hreflang="en" />
<link rel="alternate" href="https://mca.electricmura.ro/ro/" hreflang="ro" />
<link rel="alternate" href="https://mca.electricmura.ro/de/" hreflang="de" />
<link rel="alternate" href="https://mca.electricmura.ro/" hreflang="x-default" />

The first three are just fine and valid, with one pointing to itself and the other two pointing to other language versions.

The fourth, however, is troublesome. While a valid, useful value, hreflang="x-default" is intended to work with a user selection page (http status 200 - OK or maybe 300 - multiple choices). Instead, it serves a 302 - moved temporarily, which has the browser fetch the page it is forwarded to instead. Now, depending on the language that the crawler advertised when it accessed the page (or if none, depending on what your server assumed), it may land wherever.

One possible solution is to let the user decide what language to choose on the entry page instead of the automatic redirect (or maybe you could make it a timed, client-side redirect).

The other way is, if possible, to just get rid of the "x-default" meta tag - it's not too helpful and with the redirect in place there'd be no confusion anyway.

  • We'll try to remove the x-default from the plugin code. Regarding the options we have for the root URL....it seems quite impossible to let the user decide before (s)he loads the website. What I mean is that we must choose which language mca.electricmura.ro will contain. Once the user loads the website, (s)he can choose whether to switch to another language from a language selection drop bown. But before the website loads for this user, a selection must be made, otherwise she would see an empty page or a page that just says: please choose a language before we proceed. Right ? Jan 10, 2019 at 22:01
  • Right, so x-default and redirect apparently don't go well together, one of them needs to go. If you were to choose to remove the redirect, the options are either a "select your language" page (possibly with a timed redirect) or moving one of the languages to the front page as default. Removing x-default indeed seems to be the easier path.
    – lucian
    Jan 11, 2019 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.