1

Hellow,

I have 3 domains and several subdomains in Virtualmin which works fine. For the past 1 year, I didn't do any server maintenance except for updating the packages which shown in the Webmin control panel.

PROBLEM

I tried to add a subdomain(Sub server) for an existing domain. Now all the domains and subdomains point to public_html of the newly created virtual server or sub-server.

Eg: If I want to add a subdmain/Subserver to www.example1.com all the other existing domains and subdomains points to /home/example1/domains/test.example1.com/public_html

Or If I create a new virtual server for www.example2.com all the other existing domains and subdomains points to /home/example2/public_html

Webmin -> Apache Webserver -> Existing virtual host looks like this.

Type            Address     Port    Server Name             Document Root
Virtual Server  Any         80      medlk.myolddomain.com   /home/abcd/domains/medlk.myolddomain.com/public_html 
Virtual Server  Any         80      mydocs.myolddomain.com  /home/abcd/domains/mydocs.myolddomain.com/public_html 
Virtual Server  128.123.33.334  80  test.myolddomain.com /home/abcd/domains/test.myolddomain.lk/public_html 

It shows the IP address where it should show "Any".

The newly created virtual server doesn't share the IP address. Instead, all the domains with that IP address point to the newly created public_html folder.

To resolve it, either I have to,
1. Delete the new virtual server that I have created or
2. Edit virtual server -> Enabled features -> DISABLE Apache website (Remove check mark)
3. Change the IP address of that server

I have no clue about what is wrong. I would really appreciate your advice on approaching this problem.

Thank you

1

RESOLVED

For now I have resolved the issue by editing, /etc/apache2/sites-available/xxxx.conf

The change I made in the first line, <VirtualHost 128.xxx.xxx.227:80> Changed it to, <VirtualHost *:80>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.