1

I have to verify my website to different platforms such as G-Suite via meta tag verification but it fails every time and in all platforms.

This is my HTML header code:

<title>Website title</title>

<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="google-site-verification" content="secret" />

<meta name="description" content="description"/>

<meta name="network-to-verify" content="secret">

<meta name="network-to-verify" content="r7662ut80" />

All of this networks, included Google, cannot verify my website. Is it possible that I have some problems with my DNS?

More information:

  • The domain is registered on Namecheap
  • I used Laravel 5.7 (possible problems with middleware?)
  • I think that I cannot show my website here because it has adult content.
  • DNS has unmasked 'URL redirect record'.
  • HTTPS with certbot.
  • Website completely online.
  • 1
    Did you try fetching the file yourself over HTTP? Did it succeed? What HTTP return code did you get? Since you did not give any actionable information, like website name, noone can really troubleshoot the issue for you. Your problems could be as well DNS related, network related, system related, webserver related, framework related, permissions related, etc. – Patrick Mevzek Dec 14 '18 at 23:02
  • The website is completely reachable. I also try via VPN and bots. I always have a 200 HTTP response code with the correct HTML as body. The website is www.redtubeb.com (WARNING: adult content). – Stefano Cortese Dec 14 '18 at 23:19
2

I am pretty sure that this happens for one of two reasons:

  1. Unlikely, but you submit the site as http://example.com/, but it redirects to HTTPS.
  2. Most likely your server blocks some incoming requests (at least PageSpeed and Host-Tracker cannot access it).
  • I checked my website with the tools that you linked and I spotted an error in Laravel that occurred only from bots traffic. I fixed the problem and the speed score grow up and host-tracker return 200 as HTTP response code. The problem with the metatag verification persist. I'll try in a few hours, may I did it too many times and may there are some blocks. – Stefano Cortese Dec 15 '18 at 1:08
1

If not already done so, try verifying the non-www first and then verifying the www version. www is a subdomain. The non-www version must be verified first. You may also then want to put in a redirect so it resolves to just one or the other.. not both, and then elect the preferred domain via settings in Google Search Console

0

There is no such thing in DNS as a "URL redirect record". It sounds like you might be using NameCheap which claims that they have such a thing. They don't. When using that setting at NameCheap, they assign the DNS to their own web server and issue a HTTP redirect from their web server to some other URL.

If you are redirecting a domain, there is no need to verify it in Google Search Console. Instead, you should verify the final URL for your domain. I suspect that Google won't verify the domain because of the redirects.

My guess is that you actually want to use this domain name for your site. Instead of redirecting, you should assign the domain to your server's IP address using a DNS A record and configure your webserver to show the website for requests for that domain.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.