0

I can not publish my website (created with Drupal 7) with IIS 8.5 (windows server 2012 r2). I'm forwarding my domain example.com as a frame to http://192.0.2.4/mywebsite (i got static ip).

Everything is working fine, except the certificate. So I need to customize the settings.

On the router is a NAT config, my public IP 192.0.2.4:80 is forwarding to server 192.0.2.44:80. If you enter example.com you get http://192.0.2.4/mywebsite.

My objective is, to get working the website from IIS 8.5 with the certificate.

In total I have 6 domains, all of them have the same target website.

Binding in IIS is http | blank hostname | port 80 | IP unallocated

1
  • Do not redirect to an URL with an IP address in it. That is not the normal use case of HTTPS and you will have difficulties getting a certificate for this IP address, while you should have no problem getting certificates for a name. Commented Dec 7, 2018 at 14:21

1 Answer 1

0

You don't want to use forwarding or redirects of any time. You want the site to be served from your domain name.

To do so, assign a "host header value" to your site. This associated the site with the domain name.

  1. Open the site properties.
  2. Click "Advanced" next to the IP Address
  3. Add a new host header value for your main domain name that matches the certificate.
  4. Set up forwarding for the other five domain names.

There are screenshots of the process here: http://www.visualwin.com/Host-Header/

5
  • Tried without any success. Entered the nameserver of the domain but getting 404 error.
    – Yasin
    Commented Dec 10, 2018 at 12:49
  • Don't enter the nameserver. Enter the domain itself. Commented Dec 10, 2018 at 13:14
  • Same result, getting a 404 error. What settings i need for domain DNS and server dns?
    – Yasin
    Commented Dec 11, 2018 at 8:11
  • DNS needs to have A records pointing to your server's IP address. Once you verify that, you need to configure your web server to recognize the domain and show the correct set of documents for it. That is what the instructions above attempt to do. Commented Dec 11, 2018 at 12:12
  • Finally it's working and the green lock appears in browser. DNS record is pointing the server. Had to configure http/https NAT rules on router too.
    – Yasin
    Commented Dec 11, 2018 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.