I have added my site to Google webmaster and there is no errors but Google shows only home page link when i search for my site in Google search.

Inner pages are not showing.

I have well structured site with XML sitemap and valid robots.txt file, nothing is blocked in Google crawl

Please suggest any edit in my site.


If you search Google's index for your page there are actually over 400 pages available in Google search: https://www.google.com/search?q=site%3Ahostokay.com

There are only 21 URLs in your sitemap so the other pages must be getting crawled and indexed through your internal links.

On further inspection it looks like a large amount of your indexed pages are actually different translations of the same page. If you can, it might be worthwhile to change the opening <html lang="en"> to reflect the actual page language.

In Google's webmaster tools you can use the URL parameter tool to specify that the "language" parameter changes the page content and choose "translates". This should keep the pages in the index but serve them only to users who have configured those languages in the Google or browser settings.

Besides that everything seems to check out from a technical SEO perspective. You may want to employ some other SEO practices, such as link building, to gain better search page relevance.

| improve this answer | |
  • I'm using <html lang="en-US"> in all over pages of site but still google is indexing pages in multiple languages with also backend pages in multiple language. – Jennifer Anderson HostOKAY Dec 18 '18 at 12:33
  • It is wordpress site and I found all pages having two title tags, it is not the case with any SEO plugin as I have checked.. So confused. – Jennifer Anderson HostOKAY Dec 18 '18 at 12:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.