2

Our WordPress site has developed a 301 redirect loop error when web-server caching is enabled. With server caching disabled and caching plugin installed and active the issue doesn't occur, but the page loading is slower.

Our developer says the logs show no error(s). Can anyone please assist in diagnostic steps to identify the source of the issue and how to fix.

Site is running:

  • nginx/1.14.0
  • PHP version:7.0.32-3+ubuntu18.04.1+deb.sury.org+1
  • MySQL version:5.5.5-10.1.36-MariaDB-1~bionic
  • 1
    Have you tried going under the network tab in your Chrome's dev tools and clicking "Preserve log" and reloading the original page that you are seeing the redirect loop on? Sometimes you will see it chaining between pages and that might give you a clue as to what the problem is. – devnull Nov 5 '18 at 14:28
  • are you sure, this is a server cache and not a browser cache? Caching 301 redirects is a known issue, but it is a browser cache issue. – Evgeniy Nov 6 '18 at 14:46
  • Thanks @devnull for your response. All I could see was the 301 error message and not the home page. Now that server caching is disabled the issue has not re occurred, so am looking for clues as to how to tell what caused the issue. – Blue17 Nov 7 '18 at 21:50
  • Thanks for your response @evgeniy. No, I'm not sure and don't have enough experience to debug this issue. All I could see was the 301 error message and not the home page. Now that server caching is disabled the issue has not re occurred, so am looking for info as to how to identify the issue. – Blue17 Nov 7 '18 at 21:54
  • To eliminate the possibility of the browser caching a redirect, I'd recommend testing on the command line using curl. – Stephen Ostermiller Nov 14 '18 at 11:41