1

I have a Linode instance (Debian 7.4) running Apache server (2.2.22) that I mostly use for just storing files that I can then easily link to from elsewhere. I've additionally purchased a domain from GoDaddy to make such links easier. I noticed today that an image I'm storing on this server and linked to elsewhere was displaying as a broken link.

Attempting to access myserver.com in my browser results in ERR_CONNECTION_TIMED_OUT. However, apache2 is running when I check it from the Lish console (Linode's web console).

Attempting to access my instance via ssh in an actual terminal results in ssh: connect to host myserver.com port 22: Connection timed out. However, sshd is running when I check it from Lish. (The same happens trying to ssh via IP.)

Attempting to ping my server in an actual terminal (by domain or IP) results in 100% packet loss. Attempting to ping localhost from the Lish console results in 0% packet loss (of course), but attempting to ping the server's IP (or any IP other than 127.0.0.1) from Lish results in connect: Network is unreachable.

From within Lish, curl on localhost or getting the status from apache2 reports a 503 (Service Temporarily Unavailable). curl on any IP address I've tried other than 127.0.0.1 results in curl: (7) Failed to connect to X.X.X.X: Network is unreachable. curl on any domain results in curl: (6) Couldn't resolve host 'example.com'.

I can't recall making any changes to the Linode's configuration or the server settings since the last time I specifically successfully linked something on the server to someone (sharing a gzipped tarball with a friend, May 10 this year), but clearly something is wrong, and I'm not sure what the culprit might be.

Neither restarting Apache nor restarting the Linode instance fixed the issue. I've tried a few changes suggested by Google searching, including adding my domain to the hosts file and adding my domain as a ServerName to the Apache config, but none of the relatively trivial fixes I've tried have worked, and I'm not a Linux guru to feel confident in what I'm doing when it comes to network configuration stuff.

  • Is there any firewall setup somewhere? Sounds like the VM just doesnt have network access or it is being blocked via some sort of firewall. – Analog Sep 11 '18 at 20:51
  • @Analog all the iptables have no rules and an ACCEPT policy – Brian S Sep 12 '18 at 18:33
1

Contacted Linode support about the issue, and their first suggestion was to flip the auto-configure networking option on the server to enabled and reboot. This is apparently an option that Linode created at some point after I created my account (the account-wide version of the option marks the "disabled" setting as being "legacy"), which explains it being disabled, and when enabled, at boot time, Linode automatically configures network settings on the server.

While I'm still not certain what caused the issue in the first place, this automatic configuration did solve my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.