1

I host a WordPress site which isn't behaving as I'd expect.

Its taking an age to load, sometimes timing out before its finished.

However, if I have my VPN (PIA) enabled, it loads immediately and is super responsive.

Initially I thought the issue was related only to mobile content, as I didnt realise I had my VPN on and was only able to replicate the issue on my phone (Safari/iPhone), however since turning off my VPN, the site is slow and unresponsive on chrome and IE also.

Its a wordpress site on PHP 5.6, Windows Server 2012 with a caching plugin configured.

Has anyone seen anything like this before? Any suggestions on the cause?

  • 2
    Have you checked the ping/routing with the VPN off vs. VPN on? This smells less like a WordPress issue and more like a server issue – JCL1178 Aug 20 '18 at 18:25
  • so the pings seem the same, routing slightly different, as expected - tracert shows 2 less hops when using the VPN, but round trip time pretty much the same. I've had the site dev copy the site to their own webhost and it seems to load fine all of the time. I'm at a bit of a loss. I know the other host is a linux box running nginx, but still - this site should load. :( – John Aug 20 '18 at 18:55
  • If it is loading for you on the VPN it can't be an issue with your WordPress or your server. It sounds like your home ISP has problems. – Stephen Ostermiller Aug 21 '18 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.