5

I have bought a domain from GoDaddy, and I want to host a static website using firebase hosting. When connected to firebase, example.com works. But when I want to redirect www.example.com to example.com, it doesn't work. I already put token generated from Firebase into GoDaddy registrar.

It says 'Domain not verified'. enter image description here

This is my records in godaddy.

enter image description here

I have waited for a day, still it doesn't work.


What could have gone wrong in my setting up the redirection? This is my first time setting up hosting, sorry if I'm making silly mistakes.

  • In order to redirect from www to non-www, you first need to add a DNS record for the www subdomain in GoDaddy. You can do that using an A record, or CNAME. Then you'll need to add a TXT record for the Firebase verification. This guide should help with that. – dan Aug 5 '18 at 22:35
6

I have had the same issue, example.com worked just fine but www.example.com didn't. Turned out that www.example.com needs www in the name value instead of @ for reason unknown, But @ worked for example.com.

And I didn't redirect www.example.com to example.com.

So currently I have four entries in my godaddy console for my domain, two with @ and two with www. See below. Hope that helps.

GoDaddy DNS Console Settings For Firebase Hosting

  • 2
    The "Name" field is for the name of the subdomain. "www" is a subdomain. The "@" means the domain apex or "no subdomain". That should make your "unknown reason" clearer I hope. Otherwise this is a good answer. It is basically fully explaining how to create the DNS records for "www" as suggested by Dan in a comment. – Stephen Ostermiller Nov 16 '18 at 18:29
  • I'm using Google Domains but had the same problem, and the solution is the same. I needed to remove an existing row for name "www" and type "CNAME", and then add a new line for name "www" and type "A" with the values given by firebase for the values. Google Domains doesn't use multiple rows for multiple values. You can add multiple values to the same row. – Alan Wells Jan 31 '19 at 17:40
1

It was frustrating to get stuck in that, but after a while, I figure out Godaddy has a built in subdomain registration. To solve this problem, simply got GoDaddy->Select your domain->DNS Management->Scroll down to Forwarding and add subdomain www.

Example:

Example

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.