1

I have a Windows 10 computer. I am attempting to get my WAMP web server on the web but have been and continue to be unsuccessful. I believe I narrowed it down to windows though. My Motorola Cable Modem from Xfinity is port forwarded to the pc in question 192.168.0.10. All firewall settings on the modem are off and Xfinity claims they don't block ANY ports. They did not sound convincing or understanding of my intentions though.

SERVER: My WAMP server when running can be accessed locally and web pages appear. I configured the server to listen on 8080 and I access it by going to localhost:8080.

WINDOWS 10 PC: I have added inbound and outbound tcp/udp rules for port 8080 on all profiles(domain, private, and public). I have completely disabled firewall. Netstat shows port 8080 is listening just like it does for 3389 which works.

I know something is happening because I can open and close my remote desktop (3389) with the firewall but never have any success with 8080, it never opens.

I have done this in the past on a Mac, but that was with AT&T so I cant rule out the router just yet.

I have also been unsuccessful in any telnet from outside my network.

Any help would be appreciated. Thanks. Chris.

  • 1
    Have you configured port forwarding from the router to 192.168.0.10? – Stephen Ostermiller Jul 24 '18 at 14:09
  • Make sure you understand and review your firewall settings before using port forwarding. Absolutely don't use a DMZ! – closetnoc Jul 24 '18 at 14:16
  • Thank you. I will take it out of DMZ. I used this for some troubleshooting. All that said, after a week of this turns out that specific port must be blocked on my cable modem. Without changing any settings and just switching from port 8080 to 8181 everything worked. – Chris W. Jul 24 '18 at 19:11
1

Turns out for some reason my cable modem blocks 8080. I am assuming it must be reserved for another service higher in the list. I had to figure this out on my own as comcast still says it is not blocked. I changed 8080 to 8181 and kept all other settings and it worked fine.

Thanks for all the help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.