0

I have fixed the bug on 23rd June and there's no improvement of my rankings. My new articles are also not ranking, they're ranking in the 5th page, crap and old articles are ranking better.

Before the bug, I ranked top #5 for every article I post.

I do event blogging.

Any insight on how to solve this?

  • It has only been a few days! You will have to wait weeks or more depending. – closetnoc Jul 2 '18 at 2:51
  • That Yoast bug shouldn't cause a ranking drop. Your rankings dropped for some other reason. See seroundtable.com/yoast-plugin-google-drop-25842.html where Google's John Mueller says, "Sites generally shouldn’t be negatively affected by something like this. We often index pages like that for normal sites, and they usually don’t show up in search. If they do show up for normal queries, usually that’s a sign that the site has other, bigger problems." and "[the ranking drops are] more [likely] due to normal search changes than anything like this." – Stephen Ostermiller Aug 1 '18 at 19:54
  • they said it "generally", so I was affected and there are other cases too. Rankings are restored, my posts are ranking in the 2nd page now which is yet to be solved – johnrao07 Aug 2 '18 at 12:54
1

I recommend you to:

  • Double check if you switch the setting of the attachment URL to "Yes" and clear all caches (especially if you are using additional plugins or cache services).

  • Check your site index in Google and see if there are still additional URLs of image attachments indexed in Google. Depends on your domain authority/crawl budget and other different factors it can take time to reindex and get back to normal.

  • Yes I fixed that, and I uninstalled yoast now – johnrao07 Jul 3 '18 at 6:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.