I'm trying to get a site verified for AdSense. Since I want to display ads in authenticated pages too, I'm setting up Crawler Access to give a username and password to Google crawler.

In this site, there's a username/password form on the homepage, which submits to autentica.asp, which then redirects to logado.asp.

AdSense Crawler Access configuration

However, after I add this login, Google understands that logado.asp is a directory instead of a file, so it fails to verify ownership because it's appending a slash after the URL.

Google verification fail

How can I fix this?

  • 2
    Just use the DNS txt record method in alternative methods... file uploading is not as reliable because if the file gets moved or inaccessible for a period of time then they can disable the account. May 12, 2018 at 0:51
  • @SimonHayter this question isn't about Google Search Console verification. I don't think there is any DNS solution or even a file upload solution for AdSense bot being able to access login protected pages. May 14, 2018 at 11:44
  • 1
    @StephenOstermiller has the alternative methods option... screenshot is of Google Search Console, not Adsense. May 14, 2018 at 16:04

1 Answer 1


Try removing the redirect, as this seems to be making it unnecessarily complicated for the Google-bot to login to your site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.