I currently have my EC2 connected to mail.domail.com and configured A record to point EC2 ip, PTR record pointing at EC2 ip and i have a MX record for domain.com pointing at mail.domain.com, currently the config works fine but when i tried to add AWS load balancer website mail.domain.com works properly can even see the Amazon cert. but when1 i try to send mail nothing is coming in or out. i saw similar question here and tried to ask there but comment was deleted.

similar to this issue: AWS: pointing A record to load balancer on A record causes incoming email to stop functioning

the guy spoke so vaguely and none descriptive couldnt make much out of it. even if someone can explain what the guy in the link is saying in the link in a detailed way would be greeeat.

edit/update: upon viewing my header files the problem arose in my dmarc, dkim and also spf headers... according to google they all failed and according to mail-tester.com my lovely 9.7 was now a not bad 6.5... i reset all settings to dig

  • figured it out.
    – tay
    May 16 '18 at 6:23
  • Can you provide what you figured out as an answer below and then mark it as accepted? That way others will know, and you'll earn some reputation points as well. Thanks.
    – dan
    May 16 '18 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.