1

I recently created a website for a publishing company, from where the visitors can download book samples in PDF format from the company's FTP server. On Windows, macOS and Android everything works perfectly, but on iPads and iPhones I receive the following message:

You do not have permission to view "book-title.pdf"

This happens either using Safari, Chrome or Firefox. Any suggestions? Thanks in advance.

  • 3
    Why are you using FTP these days? HTTP (and HTTPS) work just fine for downloads. FTP has protocol weirdness that makes it ill suited for modern routing protocols like NAT. I view FTP as a relic of a bygone internet era. – Stephen Ostermiller Mar 21 '18 at 13:41
  • Have you tried another FTP site? There are several instances of this error being reported on iOS devices, such as this question on StackOverflow and this thread on the Apple discussion forum - but these reports are from a few years ago. What versions of iOS have you tried? FTP (including downloading PDFs) seems to work OK for me in Safari on iOS 10.3. However, in Chrome and Firefox, any FTP requests are directed back to Safari. – MrWhite Mar 21 '18 at 18:57
1

I imagine that your publishing company's server must have some sort of iOS detection and that when it detects that the user is on iOS it returns that message. If that is the case and it most likely is, you should try to resolve this issue with your publishing company.

In the event that your publishing company can't fix this iOS detection issue, you could do a work around to fix it on your own end. This would entail setting up your own iOS detection script, and if iOS is detected, changing the PDF links to the same PDF on a separate server that can allow iOS users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.