0

I have a WordPress site on a domain that used to be HTTPS, example domain https://example.com.

I now want to remove HTTPS temporarily. How do I do that?

I have tried to add the following to my .htaccess:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS}       =on
    RewriteRule ^(.*)          http://example.com/$1 [L,R]
</IfModule>

# END WordPress

However, this still gives the following error:

enter image description here

  • 2
    It looks a security certificate error. When you say that it "used to have SSL" does that mean that you no longer have a valid cert? You will need a valid cert if you want to redirect. – Stephen Ostermiller Mar 19 '18 at 14:56
  • @LarsHoldgaard I'd suggest using a CDN like CloudFlare that offers a free SSL, then you'll be able to redirect to HTTP, if you still want to (check out their PageRules for this). Note that the latest versions of Chrome require an SSL, and Google has prioritized sites with them too. – dan Mar 20 '18 at 0:06
1

As for me, on trying to visit your domain - i get no error at both versions http and https. The certificate is valid, like on screenshot: enter image description here The only thing you should do is to redirect http version to https correctly, like this:

RewriteEngine On
RewriteCond %{HTTPS} !on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
-2

Make sure wordpress isnt trying to force you back to its configured 'home' url. If that has HTTPS set on it you may be hitting that.

Magento is a pain for that too

  • It is possible that WordPress setting would cause redirect errors, but I don't think they would cause the type of error in the screenshot in the question. – Stephen Ostermiller Mar 24 '18 at 2:03
  • If the url set in wordpress includes HTTPS and the user is no longer using HTTPS it might be trying to redirect to HTTPS still resulting in the error – Timothy Frew Mar 25 '18 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.