2

I am a developer and have very little knowledge of DNS and hosting, etc. A client for an app I have inherited recently switched over to running everything over https only. However when this URL https://website.io is used it just spins and times out and will not redirect to https://www.website.io and I do not really understand why. The URL http://website.io works and redirects to https://www.website.io as expected.

I did read the posts on this site I could find that seemed related but did not find anything to solve.

The site is a ROR application hosted on AWS and uses a multi-domain SSL certificate to provide SSL to their sites. For that instance on AWS there are two load balancers, one of them handles the https (443) and has the certificate on it. The naked domain website.io is on the multi domain SSL certificate so I assumed that would solve the issue. The SSL certificate is in place and all that works fine, it is just the case of this one redirect that I do not understand, can anyone help?

  • 3
    It is not the redirect that is the problem. It is the fact that your HTTPS site is not working. There is not enough actionable information here for us to help you. You are probably better off calling technical support and starting there. Cheers!! – closetnoc Mar 7 '18 at 18:30
  • So this would need to be solved in the DNS dashboard, like Network Solutions dashboard or whatever, by the person who actually owns the domain? I do not have access to that I just develop the site but they are asking why this redirect hangs up. For me there is no tech support to call. – Rockwell Rice Mar 7 '18 at 18:32
  • You mentioned that you cannot access the site using HTTPS. Redirecting to HTTPS will only fail. Until you fix the HTTPS problem, redirecting to it will not work. It is not the redirect that is the problem. It is the fact that your site cannot be accessed using HTTPS that is the problem. This is not likely to be a DNS problem since both requests are referring to the same URL using different protocols. The web server is not responding to requests on port 443. This is the problem that needs to be addressed. – closetnoc Mar 7 '18 at 18:41
  • Sorry, I think I might not have asked the question correctly, with www.*** it it does run https, and when visiting http://website.io it will redirect to https://www.website.io. But when visiting https://website.io it hangs. The site it self does run https. – Rockwell Rice Mar 7 '18 at 18:46
  • 2
    It is one of two problems. One could be the code is wrong. Less likely, but possible. The other is that there is no certificate on website.io and it hangs there. Very likely. Without a certificate on website.io, the users browser will not see the redirect. It is quite possible that whoever set this up did not install a certificate on website.io. This is a common mistake. – closetnoc Mar 7 '18 at 18:50
1

See if your apache http server config has a line like

  • 'ServerAlias website.io'

or

  • 'ServerAlias *.website.io'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.