3

I have a problem with Google Webmasters - my main property (https://example.com/) looks like it is not verified. Even so it was verified with "HTML file upload" method a long time ago.

Due to that I have no access to user management and other staff, for example, I can't create properties for https://example.com/page1 and so on (they all look like they are not verified).

How to fix this problem? If I delete a property and create a new one, will I lose all the data (like Search queries)?

  • 1
    Is the verification file still in place? Google checks for it periodically and if you remove it from your website Google will automatically un-verify you. – Stephen Ostermiller Mar 7 '18 at 19:25
  • yes, it is still in place – Tanya Mar 8 '18 at 10:44
3

Have you visited this page?

https://www.google.com/webmasters/verification/verification?hl=en&authuser=0&theme=wmt&siteUrl=http://example.com

Put your url in instead of example.com

Search Console should tell you why your site is not verified.

If you see methods to verify your site, my personal preference is to click "Alternate Methods" and check the box for HTML file upload. Upload the HTML file to your root directory and verify.

If Google can crawl your site it should be able to verify it with the HTML file upload as long as it's on the server.

I know that you know how to verify a site, but you may need to reverify it. There are some reasons why a site can lose verification. This can happen when a site has been taken down temporarily or servers no longer function. You may need to reverify with a new HTML upload.

1

Google changed the format of the HTML verification file "a long time ago". Previously the file could be empty and simply the filename was verified. The verification file now contains the user's "key" (which is also part of the filename).

If you still had the "old" verification file in place then your site would become unverified, since Google does periodically recheck the verification method (as @StephenOstermiller pointed out in comments).

How to fix this problem?

You simply need to reverify your site (as @michaeld suggests). Either by downloading a recent verification file or by any of the other methods.

If I delete a property and create a new one ...

There is no reason to do this (for the same protocol + hostname).

  • Thank you, I will try to reverify it with HTML file upload. – Tanya Mar 8 '18 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.