2

I searched Google for my title match website is not there in the first 300.

Domain age close to 9 years. The website has been live since then, though I have actively started maintaining it from November of last year.

The domain is an exact match for the title search.

When I look for site:example.com I see results with https:// but my website is http:// and I don't plan to migrate to https://

Any ideas what could be wrong?

4

It seems that your server is allowing both connections. The main problem is that you are generating duplicate content.

It's well known that Google prefers https, that could be the reason you have secured results indexed.

Taking into account that Google is going to start showing http sites as non secure, you should migrate to https. In order to do that, if you are using Apache, use this code in .htaccess file

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
1

Make sure you are using Http: in the site Url... If you are in WordPress then you can change to HTTP: in general settings.

But Maybe you are using CDN Like as Cloudflare that offers free SSL certificates.. and if your site opened with https and shows green lock symbol in browser search bar then it means you are using SSL... for your site.

But if your site is not opening with https then it means there is the misconfiguration in site settings as I said above to do.....!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.