9

Google's new webmaster tools has a section 'Index coverage'>'Excluded'>'Submitted URL not selected as canonical'. I am getting 3 internal links in the section "Submitted URL not selected as canonical" of my website.

am not sure why these internal links are showing up there. I had updated canonical tags for these 3 links. (I am not sharing links cause may be my account marked as spam)

Google's help page has some information about it, but doesn't say how to fix it:

Submitted URL not selected as canonical: The URL is one of a set of duplicate URLs without an explicitly marked canonical page. You explicitly asked this URL to be indexed, but because it is a duplicate, and Google thinks that another URL is a better candidate for canonical, Google did not index this URL. Instead, we indexed the canonical that we selected. The difference between this status and "Google chose different canonical than user" is that, in this case, you explicitly requested indexing.

  • I assume you have hreflang setup on these URLS too? – Gnefivior Erune Feb 12 '18 at 22:52
3

You explicitely requested an indexing of some urls, through sitemap or webmaster tools, which are duplicates without canonical. The question is rather why do you want duplicated urls are explicitely indexed? It is not according to good SEO practices.

Set your duplicated urls to noindex or, at least set a canonical so Google knows what to rank instead of duplicated content - both of acts will solve the issue.

  • 2
    How do you find out what the duplicates are? When I look at that report, I can't even figure out what Google thinks is a duplicate. – Stephen Ostermiller Feb 6 '18 at 11:50
  • I also don't think setting canonicals will fix the issue. Google is choosing non-canonical URLs as the preferred canonical. I'm having that issue with my site where HTTP has canonical to HTTPS but Google is still preferring to index the HTTP URLs for a number of pages. – Stephen Ostermiller Feb 6 '18 at 11:53
  • @StephenOstermiller The URL is one of a set of duplicate URLs - for me it is enough clear. The cause of your issue with http/https, why Google preferres http over https, could be, that your http pages have much more backlinks, internal and external, as your https. – Evgeniy Feb 6 '18 at 12:15
  • In my case, there is the same content in a different language without having the language in the URL. However, the link is different Google see them as canonical. I want to index and rank in both languages!!! – Adrian P. Jan 3 at 17:51
  • @AdrianP. what about hreflangs and canonicals? Do you use them? How? – Evgeniy Jan 3 at 19:56
2

First you have to find the duplicates. It would be nice if Google told you in Search Console which URL it thinks is duplicate, but they don't divulge this information as far as I've been able to tell.

To find the duplicate you instead usually have to use Google search. Take a phrase from the page that should be unique and search for it on Google with quotes around it. That should tell you which page Google is indexing instead.

Once you know where the duplicate is you can make a decision about what to do with it. You will have several options:

  • Do nothing and let Google choose which page it thinks is duplicate on its own. Google usually only indexes one copy of a page when it finds duplicates. Having duplicate pages and letting Google deal with them automatically doesn't usually hurt your site. See What is duplicate content and how can I avoid being penalized for it on my site?
  • If you have control over both pages you can use canonical tags or redirects to tell Google which one you would prefer it indexes.
  • If the duplicate content is on some other site and the content belongs to you, you may want to try to get the other site shut down or removed from Google using DMCA.
  • You could also differentiate the pages more so they are no longer duplicate.

Edit: As suggested in the comments, you can also find the duplicate by using the "View as Search Result" link in Search Console that is available when you click on the URL in the report:

  • You can find the duplicate in Search Console by clicking the "View as search result" link, that will do an info: query for the duplicate, but it will show the canonical URL in search results. – DisgruntledGoat Jun 25 '18 at 13:01
  • @DisgruntledGoat Where do you find the "View as search result" link? – endolith Feb 1 at 2:45
  • 1
    @endolith I edited my answer to include a screenshot of where it can be found in Search Console. – Stephen Ostermiller Feb 1 at 3:07
  • Ah. All that does is open info:http://yoururl.com though? Which shows nothing for the affected URL – endolith Feb 1 at 5:24
  • 1
    For me the search results for that info query usually have one result: the page that Google picked as the canonical. Using the "Inspect URL" also now shows which page Google selected as the canonical. – Stephen Ostermiller Feb 1 at 9:14
1

The reason for this error is that Google is ignoring your AMP page. Simply because you have a responsive / mobile version that AMP page is canonicalised to. If you have a responsive / mobile version of the AMP page you have, Google is selecting that page instead of the AMP version to show at SERPs and thus saying that you have a duplicate (in terms of content).

protected by Community Mar 26 '18 at 10:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.