3

My domain has a valid and activated "Let's Encrypt!" certificate, and going to https://example.com works as it should and shows as being secure in the browser.

Through Plesk Onyx 17.5.3 I have activated the option Permanent SEO-safe 301 redirect from HTTP to HTTPS in Hosting Settings.

But when going to http://example.com, it shows a 403.4 Forbidden error and that I should use the https version of the website instead of redirecting to it.

3

In IIS Settings the option Require SSL/TLS must be turned off.

  • With it turned on, HTTP will always return a 403.4 Forbidden error.

  • With it turned off, the Permanent SEO-safe 301 redirect from HTTP to HTTPS option works, automatically rewriting the http address into a https address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.