4

I have setup Google Analytics and Google Webmasters and linked between them more than a month ago but I still don't see any data under Acquisition>SearchConsole>Queries.

I know that it doesn't show the last 1 week but I changed the date filter but still empty.

Is there anything I should do?

Please take a look at the attachment. enter image description here

2
  • do you see your queries in the GSC? Looks like a wrong implementation - wrong GA account or property or something like this...
    – Evgeniy
    Jan 24 '18 at 13:02
  • You'll want to make sure that when you setup / validated the site in Google Search Console (Webmaster Tools), you did so by connecting to your analytics account. That better ensures connectivity of data between the two. If you validated separately, make sure both analytics and GSC are tracking the same domain (www.yourdomain.com on both or non-www version on both). Jan 28 '18 at 5:33
4

It's not possible to see from this screen, but it sounds like you have your Search Console Settings in Analytics misconfigured.

Try this:

  • Sign in to your Analytics account.

  • Click Admin, and navigate to the property in which you want to enable Search Console data sharing.

  • In the PROPERTY column, click Property Settings.

  • Scroll down to Search Console Settings. You should see the URL of your website, which confirms that the website is verified in Search Console and that you have permission to make changes. If you do not see the URL, you need to add your site to Search Console. MAKE SURE THIS PROPERTY MATCHES THE PROPERTY NAME IN THE SEARCH CONSOLE. **

  • Under Search Console, select the reporting view(s) in which you want to see Search Console data.

  • Click Save.

** A common mistake in this regard is to associate the "www" or non-www domain in Analytics and the opposite in Search Console. This disparity would lead to no data being visible in Analytics.

1

Have you recently changed your website's protocol from http to https? If yes, make sure to make appropriate changes in Google analytics. The previous comment shows how to do that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.